summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJose Riha2024-06-21 22:17:55 +0200
committerJose Riha2024-06-21 22:17:55 +0200
commit613607e7f0fce6552000915d4a56c6d59f97198a (patch)
tree1d336857936589f5847491dde0351c6b5db4317c
parent7acce1108cc8bec20992b7cab0b1db6f1a4be33c (diff)
downloadaur-613607e7f0fce6552000915d4a56c6d59f97198a.tar.gz
Update
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24324c0083e3..d6d7157bbe16 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,15 @@
pkgbase = deltachat-cursed
pkgdesc = Delta Chat client for the command line
- pkgver = 0.8.0
+ pkgver = 0.9.0
pkgrel = 1
url = https://github.com/adbenitez/deltachat-cursed
arch = any
license = GPL
- makedepends = python-setuptools
depends = python-notify-py
depends = python-urwid_readline
- depends = python-deltachat
+ depends = python-deltachat2
depends = python-emoji
- source = https://files.pythonhosted.org/packages/df/7e/85dcd4b7f84ede4d9ff2983234bd89e6fa095b9517fc1a43a5bec97a7040/deltachat_cursed-0.8.0.tar.gz
- sha256sums = cd6915d3acfeeabe00bb9d0e8878aee19e48060d4fd090323ae6920171981440
+ source = https://files.pythonhosted.org/packages/9f/3f/0acb29bbb76720a1071809b2118cc5b1e734f8d6ddf08b5904c4d594a5e4/deltachat-cursed-0.9.0.tar.gz
+ sha256sums = 3a8f7e061f591a9091ae437a91a845de5ffb792719d0f1e644aa7e846250886d
pkgname = deltachat-cursed
diff --git a/PKGBUILD b/PKGBUILD
index 792bfe9a0c2e..03b3309e1b33 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,26 +1,25 @@
# Maintainer: Jose Riha <jose1711 gmail com>
pkgname=deltachat-cursed
-_module=deltachat_cursed
-pkgver=0.8.0
+pkgver=0.9.0
pkgrel=1
pkgdesc="Delta Chat client for the command line"
url="https://github.com/adbenitez/deltachat-cursed"
-depends=(python-notify-py python-urwid_readline python-deltachat python-emoji)
-makedepends=(python-setuptools)
+depends=(python-notify-py python-urwid_readline python-deltachat2 python-emoji)
license=('GPL')
arch=('any')
-source=("https://files.pythonhosted.org/packages/df/7e/85dcd4b7f84ede4d9ff2983234bd89e6fa095b9517fc1a43a5bec97a7040/deltachat_cursed-${pkgver}.tar.gz")
-sha256sums=('cd6915d3acfeeabe00bb9d0e8878aee19e48060d4fd090323ae6920171981440')
+source=("https://files.pythonhosted.org/packages/9f/3f/0acb29bbb76720a1071809b2118cc5b1e734f8d6ddf08b5904c4d594a5e4/deltachat-cursed-${pkgver}.tar.gz")
+sha256sums=('3a8f7e061f591a9091ae437a91a845de5ffb792719d0f1e644aa7e846250886d')
build() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py build
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python -m build --wheel --no-isolation
}
package() {
- cd "${srcdir}/${_module}-${pkgver}"
- python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ python -m installer --destdir="$pkgdir" dist/*.whl
+ # avoid conflict with community/git-delta
rm "${pkgdir}/usr/bin/delta"
install -Dm644 docs/user-guide.md "${pkgdir}/usr/share/doc/deltachat-cursed/user_guide.md"
}