summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortercean2022-08-23 02:42:00 +0200
committertercean2022-08-23 02:42:00 +0200
commit9db9a84239f75859dd8b91addb58bd2dcd0159e1 (patch)
tree3261c9c16591acf3ba47476c35c48d0c3f4aa394
parentfbdb79bcb2b9ae3c6f9618fc3409c07ea4ee82ce (diff)
downloadaur-9db9a84239f75859dd8b91addb58bd2dcd0159e1.tar.gz
1.32.1
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD12
-rw-r--r--deltachat-desktop.sh2
-rw-r--r--static_build_info.patch2
4 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dc83b2a03386..3bed9a01d591 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deltachat-desktop
pkgdesc = A privacy oriented chat application built on e-mail
- pkgver = 1.32.0
- pkgrel = 2
+ pkgver = 1.32.1
+ pkgrel = 1
url = https://github.com/deltachat/deltachat-desktop
arch = any
license = GPL
@@ -10,15 +10,15 @@ pkgbase = deltachat-desktop
makedepends = rustup
makedepends = python
makedepends = unzip
- depends = electron14
+ depends = electron18
conflicts = deltachat-desktop-git
- source = deltachat-desktop-1.32.0.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.32.0.tar.gz
+ source = deltachat-desktop-1.32.1.tar.gz::https://github.com/deltachat/deltachat-desktop/archive/v1.32.1.tar.gz
source = deltachat-desktop.desktop
source = deltachat-desktop.sh
source = static_build_info.patch
- sha256sums = 2f02bed52cce0ea93d9c97006ed9df5350c38864196cdfa540eaa22398e98a63
+ sha256sums = 16b7422ee4aeb31303b498e5da6456646ad92faf8a419f40b6ee8dc14ec5a16b
sha256sums = 39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1
- sha256sums = b628ed45534a227a5e7e7d75acffb912fc12095f78c23cfd4021cf1ee2aed267
- sha256sums = 371cf008d9abee3ac567c1f05ddffc58f5446e2dba0a7b43a97716481586989c
+ sha256sums = cd5c0044fe28b31788b9d0efaac94ba6af8baadad6d122ce19c37874905af27b
+ sha256sums = 775609a8c491ba89235c89c8d0aa69bdd018fe047c52cfb0d6c1314ed66a3c00
pkgname = deltachat-desktop
diff --git a/PKGBUILD b/PKGBUILD
index 03b7150b0793..e7b3b40a37ea 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: tercean <cg@zknt.org>
pkgname=deltachat-desktop
-pkgver=1.32.0
-pkgrel=2
+pkgver=1.32.1
+pkgrel=1
pkgdesc="A privacy oriented chat application built on e-mail"
arch=("any")
url="https://github.com/deltachat/deltachat-desktop"
license=("GPL")
-depends=('electron14')
+depends=('electron18')
makedepends=('npm' 'nodejs>=16' 'rustup' 'python' 'unzip')
conflicts=("deltachat-desktop-git")
source=(
@@ -15,10 +15,10 @@ source=(
"deltachat-desktop.sh"
"static_build_info.patch"
)
-sha256sums=('2f02bed52cce0ea93d9c97006ed9df5350c38864196cdfa540eaa22398e98a63'
+sha256sums=('16b7422ee4aeb31303b498e5da6456646ad92faf8a419f40b6ee8dc14ec5a16b'
'39bae164c234b3c89e7ae2bde89753c90065df7f37fece084f7f5acccbb9f1f1'
- 'b628ed45534a227a5e7e7d75acffb912fc12095f78c23cfd4021cf1ee2aed267'
- '371cf008d9abee3ac567c1f05ddffc58f5446e2dba0a7b43a97716481586989c')
+ 'cd5c0044fe28b31788b9d0efaac94ba6af8baadad6d122ce19c37874905af27b'
+ '775609a8c491ba89235c89c8d0aa69bdd018fe047c52cfb0d6c1314ed66a3c00')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
diff --git a/deltachat-desktop.sh b/deltachat-desktop.sh
index ccc7ea1724fb..2fc938a1db2e 100644
--- a/deltachat-desktop.sh
+++ b/deltachat-desktop.sh
@@ -1,4 +1,4 @@
#!/bin/bash
-cd /opt/DeltaChat/electron_app && electron14 . "$@"
+cd /opt/DeltaChat/electron_app && electron18 . "$@"
diff --git a/static_build_info.patch b/static_build_info.patch
index dc47cb2e1f20..883656896983 100644
--- a/static_build_info.patch
+++ b/static_build_info.patch
@@ -39,7 +39,7 @@ diff --unified --recursive --text orig/bin/build-shared-version-info.js patched/
- const git_ref =
- git_describe + (git_branch === 'master' ? '' : '-' + git_branch)
- return git_ref
-+ return "tags/v1.32.0"
++ return "tags/v1.32.1"
}
async function gatherBuildInfo() {