summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjikstra2018-12-17 19:06:09 +0100
committerjikstra2018-12-17 19:10:17 +0100
commitae3030b50a6b90a3da115c6652338ce89af54f31 (patch)
tree135ef2767f2a6233e7628f7c1c0b98a6398f7f87
downloadaur-ae3030b50a6b90a3da115c6652338ce89af54f31.tar.gz
Add PKGBUILD, .SRCINFO & needed files
-rw-r--r--.SRCINFO24
-rwxr-xr-xPKGBUILD59
-rw-r--r--deltachat-desktop.desktop10
-rw-r--r--deltachat-desktop.sh4
4 files changed, 97 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d22ef52202d0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = deltachat-desktop-git
+ pkgdesc = A privacy oriented chat application built on e-mail
+ pkgver = v0.90.1.r20.gb24fb2b
+ pkgrel = 1
+ url = https://github.com/deltachat/deltachat-desktop
+ arch = any
+ license = GPL
+ makedepends = npm
+ makedepends = git
+ depends = openssl
+ depends = sqlite
+ depends = libsasl
+ depends = zlib
+ depends = bzip2
+ depends = electron
+ source = deltachat-desktop-git::git://github.com/deltachat/deltachat-desktop.git
+ source = deltachat-desktop.desktop
+ source = deltachat-desktop.sh
+ sha256sums = SKIP
+ sha256sums = 5772cf1942bd4fb1ecddfff4a4ad4783140960b1d109861908567fbd0fc3a553
+ sha256sums = eba972f8f3920d3328805373efac345e6e112ed9cf0f5d2ee72a6b6d9089fe65
+
+pkgname = deltachat-desktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..c000aa7f1dee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer: Jikstra <jikstra@disroot.org>
+pkgname=deltachat-desktop-git
+pkgver=v0.90.1.r20.gb24fb2b
+pkgrel=1
+pkgdesc="A privacy oriented chat application built on e-mail"
+arch=("any")
+url="https://github.com/deltachat/deltachat-desktop"
+license=("GPL")
+depends=('openssl' 'sqlite' 'libsasl' 'zlib' 'bzip2' 'electron')
+makedepends=("npm" "git")
+source=(
+ "deltachat-desktop-git::git://github.com/deltachat/deltachat-desktop.git"
+ "deltachat-desktop.desktop"
+ "deltachat-desktop.sh"
+)
+
+sha256sums=(
+ "SKIP"
+ "5772cf1942bd4fb1ecddfff4a4ad4783140960b1d109861908567fbd0fc3a553"
+ "eba972f8f3920d3328805373efac345e6e112ed9cf0f5d2ee72a6b6d9089fe65"
+)
+
+
+pkgver() {
+ cd "$srcdir/${pkgname}"
+
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+
+prepare() {
+ cd "$srcdir/${pkgname}"
+
+ npm install
+ npm run build
+
+ # Delete development dependencies, we don't need them anymore
+ npm prune --production
+}
+
+
+package() {
+ cd "$srcdir/${pkgname}"
+
+ install -d "${pkgdir}/opt/DeltaChat/electron_app"
+ cp -r node_modules images src build static _locales "${pkgdir}/opt/DeltaChat/electron_app"
+ cp index.js package.json "${pkgdir}/opt/DeltaChat/electron_app"
+
+ install -d "${pkgdir}/opt/DeltaChat/electron_app/conversations"
+ cp -r conversations/build "${pkgdir}/opt/DeltaChat/electron_app/conversations"
+
+ install -Dm644 "${srcdir}/deltachat-desktop.desktop" "${pkgdir}/usr/share/applications/deltachat.desktop"
+ install -Dm755 "${srcdir}/deltachat-desktop.sh" "${pkgdir}/opt/DeltaChat/deltachat"
+ install -d "${pkgdir}/usr/bin"
+ ln -s "${pkdir}/opt/DeltaChat/deltachat" "${pkgdir}/usr/bin/deltachat"
+
+ install -Dm644 ./images/deltachat.png "${pkgdir}/usr/share/icons/hicolor/scalable/apps/deltachat.png"
+}
+
diff --git a/deltachat-desktop.desktop b/deltachat-desktop.desktop
new file mode 100644
index 000000000000..978db332d678
--- /dev/null
+++ b/deltachat-desktop.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=DeltaChat
+Comment=A privacy oriented chat application built on e-mail
+Exec="/opt/DeltaChat/deltachat"
+Terminal=false
+Type=Application
+Icon=deltachat
+StartupWMClass="DeltaChat"
+Categories=Network;InstantMessaging;Chat;IRCClient
+
diff --git a/deltachat-desktop.sh b/deltachat-desktop.sh
new file mode 100644
index 000000000000..da3a37915be3
--- /dev/null
+++ b/deltachat-desktop.sh
@@ -0,0 +1,4 @@
+#!/bin/bash
+
+electron /opt/DeltaChat/electron_app "$@"
+