summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorjikstra2019-01-18 17:40:44 +0100
committerjikstra2019-01-18 17:40:44 +0100
commitd5218c8f5c32ada64bb931d3dd9ef9079955238b (patch)
tree958bbab8580bfcb181062627551bfe1ed4b44b66
parent90c4cf5eca407e8c732366fa00cdcc637becca03 (diff)
downloadaur-d5218c8f5c32ada64bb931d3dd9ef9079955238b.tar.gz
Updated pkgbuild to use bundled electron
-rwxr-xr-xPKGBUILD19
-rw-r--r--deltachat-desktop.sh2
2 files changed, 15 insertions, 6 deletions
diff --git a/PKGBUILD b/PKGBUILD
index baaa337b55b6..daca2e756f0c 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,12 +1,12 @@
# Maintainer: Jikstra <jikstra@disroot.org>
pkgname=deltachat-desktop-git
-pkgver=v0.98.1.r31.g722cac2
+pkgver=v0.98.2.r10.g8a456f7
pkgrel=1
pkgdesc="A privacy oriented chat application built on e-mail"
arch=("any")
url="https://github.com/deltachat/deltachat-desktop"
license=("GPL")
-depends=('openssl' 'sqlite' 'libsasl' 'zlib' 'bzip2' 'electron')
+depends=('openssl' 'sqlite' 'libsasl' 'zlib' 'bzip2')
makedepends=("npm" "git")
source=(
"deltachat-desktop-git::git://github.com/deltachat/deltachat-desktop.git"
@@ -17,7 +17,7 @@ source=(
sha256sums=(
"SKIP"
"5772cf1942bd4fb1ecddfff4a4ad4783140960b1d109861908567fbd0fc3a553"
- "eba972f8f3920d3328805373efac345e6e112ed9cf0f5d2ee72a6b6d9089fe65"
+ "a0e3e682621f644133f21cf1844da6661378d1065f28e0dfd25f4636a6ca6dc2"
)
@@ -33,9 +33,18 @@ prepare() {
npm install
npm run build
-
+
+ # Save electron. this will otherwise get removed by the prune command
+ mkdir -p tmp_node_modules
+ mkdir -p tmp_node_modules/.bin
+ mv node_modules/electron tmp_node_modules
+
# Delete development dependencies, we don't need them anymore
- npm prune --production
+ npm prune --production
+
+ # Put back electron
+ mv tmp_node_modules/* node_modules
+ rm -rf tmp_node_modules
}
diff --git a/deltachat-desktop.sh b/deltachat-desktop.sh
index da3a37915be3..326a6a1a9bf5 100644
--- a/deltachat-desktop.sh
+++ b/deltachat-desktop.sh
@@ -1,4 +1,4 @@
#!/bin/bash
-electron /opt/DeltaChat/electron_app "$@"
+cd /opt/DeltaChat/electron_app && ./node_modules/electron/cli.js . "$@"