summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorskydrome2015-09-14 12:47:40 -0400
committerskydrome2015-09-14 12:47:40 -0400
commit35832c2cb528f468103c4624140a139ebe4ba457 (patch)
tree79ebbeace870edcc488d1f233e61565b3311e5b6
parenta745e285a309b49cb4b16e20a098ee87a4076f92 (diff)
downloadaur-35832c2cb528f468103c4624140a139ebe4ba457.tar.gz
bump version
-rw-r--r--.SRCINFO3
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD32
3 files changed, 31 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb92f5c6e0fb..5cdc658f1143 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deluge-git
pkgdesc = A bittorrent client written with python and pygtk - Git Version
- pkgver = 2.0.0.dev381
+ pkgver = 2.0.0.dev451
pkgrel = 1
url = http://deluge-torrent.org
install = deluge.install
@@ -21,6 +21,7 @@ pkgbase = deluge-git
depends = python2-xdg
depends = python2-twisted
depends = xdg-utils
+ optdepends = python2-pillow
optdepends = librsvg: needed for gtk ui
optdepends = pygtk: needed for gtk ui
optdepends = python2-mako: needed for web ui
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0f1e3d823c9d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+deluge/
+pkg/
+src/
+*.pkg.tar
diff --git a/PKGBUILD b/PKGBUILD
index 3aa1124ab44a..a1a387106699 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
# PKGBUILD based on extra\deluge's PKGBUILD, adapted for -git version by Berseker
pkgname=deluge-git
-pkgver=2.0.0.dev381
+pkgver=2.0.0.dev451
pkgrel=1
pkgdesc="A bittorrent client written with python and pygtk - Git Version"
arch=('any')
@@ -14,12 +14,25 @@ conflicts=('deluge' 'deluge-stable-git')
provides=('deluge')
install='deluge.install'
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'libtorrent-rasterbar' 'python2-service-identity'
- 'python2-chardet' 'python2-pyopenssl' 'python2-xdg' 'python2-twisted' 'xdg-utils')
+depends=('desktop-file-utils'
+ 'hicolor-icon-theme'
+ 'libtorrent-rasterbar'
+ 'python2-service-identity'
+ 'python2-chardet'
+ 'python2-pyopenssl'
+ 'python2-xdg'
+ 'python2-twisted'
+ 'xdg-utils')
-makedepends=('intltool' 'librsvg' 'pygtk' 'python2-mako' 'python2-setuptools' 'git' )
+makedepends=('intltool'
+ 'librsvg'
+ 'pygtk'
+ 'python2-mako'
+ 'python2-setuptools'
+ 'git' )
-optdepends=('librsvg: needed for gtk ui'
+optdepends=('python2-pillow'
+ 'librsvg: needed for gtk ui'
'pygtk: needed for gtk ui'
'python2-mako: needed for web ui'
'python2-notify: libnotify notifications'
@@ -39,6 +52,11 @@ pkgver() {
python2 version.py
}
+prepare() {
+ cd "$srcdir/deluge/deluge/ui/data/icons"
+ ln -s hicolor/scalable scalable
+}
+
build() {
cd "$srcdir/deluge"
python2 setup.py build
@@ -48,8 +66,8 @@ package() {
cd "$srcdir/deluge"
python2 setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- install -d "$pkgdir/srv"
- install -d -m 664 "$pkgdir/srv/deluge"
+ install -d "$pkgdir/srv"
+ install -dm664 "$pkgdir/srv/deluge"
install -Dm644 "deluge/ui/data/pixmaps/deluge.svg" "$pkgdir/usr/share/pixmaps/deluge.svg"
install -Dm644 "$srcdir/deluged.service" "$pkgdir/usr/lib/systemd/system/deluged.service"
install -Dm644 "$srcdir/deluge-web.service" "$pkgdir/usr/lib/systemd/system/deluge-web.service"