summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2019-05-20 19:40:49 +0000
committerDaniel Bermond2019-05-20 19:40:49 +0000
commit645182c7c842c008a24d1b7afe4952d4cb5b2733 (patch)
treedcf218095f7ba9ae8179349d617319164ff92a5b
parentd3129b20a2ecfc9a84470ccba67789e06ef33e75 (diff)
downloadaur-645182c7c842c008a24d1b7afe4952d4cb5b2733.tar.gz
Update dependencies. Fix shebang in some scripts.
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD27
2 files changed, 17 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37420cc7e626..4ef68a5a1b98 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deluge-git
pkgdesc = A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)
- pkgver = 2.0.0b2.dev331.gf885edd7f
+ pkgver = 2.0.0b2.dev342.g72d363968
pkgrel = 1
epoch = 1
url = https://deluge-torrent.org/
@@ -17,24 +17,23 @@ pkgbase = deluge-git
depends = libtorrent-rasterbar
depends = python2-twisted
depends = python2-pyasn1
+ depends = python2-rencode
depends = python2-pyopenssl
depends = python2-xdg
depends = python2-pillow
+ depends = python2-mako
depends = python2-chardet
depends = python2-six
depends = python2-setproctitle
depends = python2-zope-interface
depends = python2-service-identity
- depends = python2-rencode
depends = python2-setuptools
depends = xdg-utils
optdepends = librsvg: gtk ui
optdepends = pygtk: gtk ui
optdepends = python2-gobject: gtk ui
- optdepends = python2-mako: web ui
optdepends = python2-notify: libnotify notifications
optdepends = python2-pygame: audible notifications
- optdepends = python2-rencode: encoding library
optdepends = python2-dbus: show item location in filemanager
optdepends = geoip: display peer locations
provides = deluge
diff --git a/PKGBUILD b/PKGBUILD
index 5509034d5963..9cccb7f66a92 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,7 +6,7 @@
pkgname=deluge-git
_srcname=deluge
-pkgver=2.0.0b2.dev331.gf885edd7f
+pkgver=2.0.0b2.dev342.g72d363968
pkgrel=1
epoch=1
pkgdesc="A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)"
@@ -14,25 +14,23 @@ arch=('any')
url='https://deluge-torrent.org/'
license=('GPL3')
depends=('desktop-file-utils' 'hicolor-icon-theme' 'libtorrent-rasterbar'
- 'python2-twisted' 'python2-pyasn1' 'python2-pyopenssl' 'python2-xdg'
- 'python2-pillow' 'python2-chardet' 'python2-six' 'python2-setproctitle'
- 'python2-zope-interface' 'python2-service-identity' 'python2-rencode'
- 'python2-setuptools' 'xdg-utils')
-makedepends=(
- # binary repositories:
- 'git' 'intltool' 'librsvg' 'pygtk' 'python2-mako'
- # AUR:
- 'slimit2'
-)
+ 'python2-twisted' 'python2-pyasn1' 'python2-rencode' 'python2-pyopenssl'
+ 'python2-xdg' 'python2-pillow' 'python2-mako' 'python2-chardet' 'python2-six'
+ 'python2-setproctitle' 'python2-zope-interface' 'python2-service-identity'
+ 'python2-setuptools' 'xdg-utils')
optdepends=('librsvg: gtk ui'
'pygtk: gtk ui'
'python2-gobject: gtk ui'
- 'python2-mako: web ui'
'python2-notify: libnotify notifications'
'python2-pygame: audible notifications'
- 'python2-rencode: encoding library'
'python2-dbus: show item location in filemanager'
'geoip: display peer locations')
+makedepends=(
+ # binary repositories:
+ 'git' 'intltool' 'librsvg' 'pygtk' 'python2-mako'
+ # AUR:
+ 'slimit2'
+)
provides=('deluge')
conflicts=('deluge')
source=('git://deluge-torrent.org/deluge.git#branch=develop' # official repository
@@ -66,6 +64,9 @@ package() {
python2 setup.py install --prefix='/usr' --root="$pkgdir" --skip-build --optimize='1'
+ sed -i '1s/$/2/' "${pkgdir}/usr/lib/python2.7/site-packages/deluge/path_chooser_common.py"
+ sed -i '1s/$/2/' "${pkgdir}/usr/lib/python2.7/site-packages/deluge/ui/gtk3/path_combo_chooser.py"
+
install -D -m644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
install -D -m644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"