summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2020-04-01 12:33:34 +0000
committerDaniel Bermond2020-04-01 12:33:34 +0000
commitbd126d5bb4f97703be75644a4b7793927b6ad61d (patch)
tree239c1191241993d0d49150fbfa6ede7c78356eef
parenta80e73166df3f057811fc308fe43fbb34061e840 (diff)
downloadaur-bd126d5bb4f97703be75644a4b7793927b6ad61d.tar.gz
Update dependencies. Cosmetic changes.
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD42
2 files changed, 32 insertions, 46 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 058ac7f30baf..b069253e3ec3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deluge-git
pkgdesc = A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)
- pkgver = 2.0.0b2.dev360.gbe74d96c6
+ pkgver = 2.0.4.dev23.g2f1c008a2
pkgrel = 1
epoch = 1
url = https://deluge-torrent.org/
@@ -10,42 +10,40 @@ pkgbase = deluge-git
checkdepends = python-pytest-cov
checkdepends = python-hypothesis
checkdepends = python-mock
- checkdepends = python-gobject
checkdepends = python-cairo
checkdepends = xorg-server-xvfb
checkdepends = gtk3
makedepends = git
makedepends = intltool
makedepends = librsvg
- makedepends = pygtk
- makedepends = slimit-git
- depends = desktop-file-utils
- depends = hicolor-icon-theme
- depends = libtorrent-rasterbar
+ makedepends = python-gobject
+ makedepends = slimit
depends = python-twisted
- depends = python-pyasn1
- depends = python-rencode
depends = python-pyopenssl
+ depends = python-rencode
depends = python-xdg
- depends = python-pillow
- depends = python-mako
- depends = python-chardet
depends = python-six
- depends = python-setproctitle
depends = python-zope-interface
+ depends = python-chardet
+ depends = python-setproctitle
+ depends = python-pillow
+ depends = python-pyasn1
+ depends = python-mako
depends = python-service-identity
depends = python-setuptools
depends = xdg-utils
- optdepends = librsvg: for GTK user interface
+ depends = libtorrent-rasterbar
+ depends = desktop-file-utils
+ depends = hicolor-icon-theme
+ optdepends = geoip: for displaying peer locations
optdepends = gtk3: for GTK user interface
- optdepends = pygtk: for GTK user interface
- optdepends = python-cairo: for GTK user interface
optdepends = python-gobject: for GTK user interface and desktop popup notifications plugin
- optdepends = libnotify: for dektop popup notifications plugin
- optdepends = python-pygame: for sound notifications plugin
+ optdepends = python-cairo: for GTK user interface
+ optdepends = librsvg: for GTK user interface
optdepends = python-dbus: for showing item location in filemanager
- optdepends = geoip: for displaying peer locations
+ optdepends = python-pygame: for sound notifications plugin
optdepends = python-distro: for OS platform information
+ optdepends = libnotify: for dektop popup notifications plugin
provides = deluge
conflicts = deluge
source = git://deluge-torrent.org/deluge.git#branch=develop
diff --git a/PKGBUILD b/PKGBUILD
index 296982964aaa..6c3e1e281a3d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,33 @@
-# Maintainer : Daniel Bermond < gmail-com: danielbermond >
+# Maintainer : Daniel Bermond <dbermond@archlinux.org>
# Contributor: Jan "heftig" Steffens <jan.steffens@gmail.com>
# Contributor: Ionut Biru <ibiru@archlinux.org>
# Contributor: Hugo Doria <hugo@archlinux.org>
pkgname=deluge-git
-pkgver=2.0.0b2.dev360.gbe74d96c6
+pkgver=2.0.4.dev23.g2f1c008a2
pkgrel=1
epoch=1
pkgdesc="A BitTorrent client with multiple user interfaces in a client/server model (git version, 'develop' branch)"
arch=('any')
url='https://deluge-torrent.org/'
license=('GPL3')
-depends=('desktop-file-utils' 'hicolor-icon-theme' 'libtorrent-rasterbar'
- 'python-twisted' 'python-pyasn1' 'python-rencode' 'python-pyopenssl'
- 'python-xdg' 'python-pillow' 'python-mako' 'python-chardet' 'python-six'
- 'python-setproctitle' 'python-zope-interface' 'python-service-identity'
- 'python-setuptools' 'xdg-utils')
-optdepends=('librsvg: for GTK user interface'
+depends=('python-twisted' 'python-pyopenssl' 'python-rencode' 'python-xdg'
+ 'python-six' 'python-zope-interface' 'python-chardet'
+ 'python-setproctitle' 'python-pillow' 'python-pyasn1' 'python-mako'
+ 'python-service-identity' 'python-setuptools' 'xdg-utils'
+ 'libtorrent-rasterbar' 'desktop-file-utils' 'hicolor-icon-theme')
+optdepends=('geoip: for displaying peer locations'
'gtk3: for GTK user interface'
- 'pygtk: for GTK user interface'
- 'python-cairo: for GTK user interface'
'python-gobject: for GTK user interface and desktop popup notifications plugin'
- 'libnotify: for dektop popup notifications plugin'
- 'python-pygame: for sound notifications plugin'
+ 'python-cairo: for GTK user interface'
+ 'librsvg: for GTK user interface'
'python-dbus: for showing item location in filemanager'
- 'geoip: for displaying peer locations'
- 'python-distro: for OS platform information')
-makedepends=('git' 'intltool' 'librsvg' 'pygtk' 'slimit-git')
+ 'python-pygame: for sound notifications plugin'
+ 'python-distro: for OS platform information'
+ 'libnotify: for dektop popup notifications plugin')
+makedepends=('git' 'intltool' 'librsvg' 'python-gobject' 'slimit')
checkdepends=('python-pytest-twisted' 'python-pytest-cov' 'python-hypothesis'
- 'python-mock' 'python-gobject' 'python-cairo' 'xorg-server-xvfb'
- 'gtk3')
+ 'python-mock' 'python-cairo' 'xorg-server-xvfb' 'gtk3')
provides=('deluge')
conflicts=('deluge')
BUILDENV=('!check')
@@ -43,41 +41,31 @@ sha256sums=('SKIP'
pkgver() {
cd deluge
-
local _internalver
local _shorthash
-
_internalver="$(python version.py)"
_shorthash="$(git rev-parse --short HEAD)"
-
printf '%s.g%s' "$_internalver" "$_shorthash"
}
build() {
cd deluge
-
python setup.py build
}
check() {
cd deluge
-
xvfb-run python setup.py test
}
package() {
cd deluge
-
python setup.py install --prefix='/usr' --root="$pkgdir" --skip-build --optimize='1'
-
install -D -m644 "${srcdir}/deluged.service" "${pkgdir}/usr/lib/systemd/system/deluged.service"
install -D -m644 "${srcdir}/deluge-web.service" "${pkgdir}/usr/lib/systemd/system/deluge-web.service"
-
ln -s deluge.png "${pkgdir}/usr/share/pixmaps/deluge-panel.png"
-
printf '%s\n' 'u deluge - "Deluge BitTorrent daemon" /srv/deluge' |
install -D -m644 /dev/stdin "${pkgdir}/usr/lib/sysusers.d/deluge.conf"
-
printf '%s\n' 'd /srv/deluge 0775 deluge deluge' |
install -D -m644 /dev/stdin "${pkgdir}/usr/lib/tmpfiles.d/deluge.conf"
}