summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgetzze2019-11-14 23:48:13 +0000
committergetzze2019-11-14 23:48:13 +0000
commit5190caaf6e62b937c00668568ca2eae8917e596e (patch)
tree64385833d76b3d8e25df5cdb41921b1ae7f3472d
parentcb583e499024270d4459b2bf9532d3a325069810 (diff)
downloadaur-5190caaf6e62b937c00668568ca2eae8917e596e.tar.gz
update python version 3.8 and build from source
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD17
2 files changed, 15 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3e9388e24e5a..b96e08e07c9d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = deluge-labelplus
pkgdesc = LabelPlus is a plugin for Deluge for labeling torrent, with much more functionalities that the builtin Labels.
pkgver = 0.3.2.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bdutro/deluge-labelplus
arch = any
license = GPL3
+ makedepends = python-setuptools
depends = deluge
- noextract = LabelPlus-0.3.2.4-py3.7.egg
- source = https://github.com/bdutro/deluge-labelplus/releases/download/v0.3.2.4/LabelPlus-0.3.2.4-py3.7.egg
- sha256sums = 5f9c1f9598eaca53bf512a70c0697c50af614c36cc4d27e5ab0c877e7979eebc
+ source = https://github.com/bdutro/deluge-labelplus/archive/v0.3.2.4.tar.gz
+ sha256sums = 1b100872c14c2507bc9e58a1d13e2b8e47cfaf9a6bf4688a665cc1b4acd775fc
pkgname = deluge-labelplus
diff --git a/PKGBUILD b/PKGBUILD
index d59220516b90..1db93c08021b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,8 +2,7 @@
pkgname=deluge-labelplus
pkgver=0.3.2.4
-pkgrel=1
-_pyver=3.7
+pkgrel=2
pkgdesc="LabelPlus is a plugin for Deluge for labeling torrent, with much more functionalities that the builtin Labels."
arch=('any')
## Set to fork until included upstream
@@ -11,12 +10,18 @@ url="https://github.com/bdutro/deluge-labelplus"
#url="https://github.com/ratanakvlun/deluge-labelplus"
license=(GPL3)
depends=('deluge')
-source=($url/releases/download/v$pkgver/LabelPlus-$pkgver-py${_pyver}.egg)
+makedepends=('python-setuptools')
+source=($url/archive/v$pkgver.tar.gz)
+sha256sums=('1b100872c14c2507bc9e58a1d13e2b8e47cfaf9a6bf4688a665cc1b4acd775fc')
-sha256sums=('5f9c1f9598eaca53bf512a70c0697c50af614c36cc4d27e5ab0c877e7979eebc')
-noextract=(LabelPlus-$pkgver-py${_pyver}.egg)
+build() {
+ cd "${srcdir}/$pkgname-$pkgver"
+ python setup.py bdist_egg
+}
package() {
- install -Dm644 "LabelPlus-$pkgver-py${_pyver}.egg" "${pkgdir}/usr/lib/python${_pyver}/site-packages/deluge/plugins/LabelPlus-$pkgver-py${_pyver}.egg"
+ cd "${srcdir}/$pkgname-$pkgver"/dist
+ local _pyver=$(python -c 'import sys; print(".".join(map(str, sys.version_info[:2])))')
+ install -Dm644 "LabelPlus-$pkgver-py${_pyver}.egg" "${pkgdir}/usr/lib/python${_pyver}/site-packages/deluge/plugins/LabelPlus-$pkgver-py${_pyver}.egg"
}