summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-07-02 13:50:50 +0200
committerMarcell Meszaros2022-07-02 13:50:50 +0200
commit291b427c79fb4a05c51803000821afc756b66f8a (patch)
treefbe9f7cf468a4c54febfe08d91b990fdd3b5143e
parente7be6bb777edc9c986f0bb522e7081f839bb9666 (diff)
downloadaur-291b427c79fb4a05c51803000821afc756b66f8a.tar.gz
1.3.15-12: fix hashbangs
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD13
2 files changed, 7 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eb44d4204a5d..80b722de2a23 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,12 @@
pkgbase = deluge1
pkgdesc = BitTorrent client with multiple interfaces, using a client/server model (legacy 1.3.x version)
pkgver = 1.3.15
- pkgrel = 11
+ pkgrel = 12
url = https://deluge-torrent.org/
arch = any
license = GPL3
makedepends = intltool
makedepends = python2-setuptools
- depends = python2
optdepends = libtorrent-rasterbar<=1:1.2.10-4: for the daemon
optdepends = python2-geoip: for peer IP geolocation
optdepends = python2-pygame: audible notifications for GTK client
@@ -36,6 +35,7 @@ pkgbase = deluge1
pkgname = deluge1
depends = hicolor-icon-theme
+ depends = python2
depends = python2-chardet
depends = python2-pyopenssl
depends = python2-pyxdg
diff --git a/PKGBUILD b/PKGBUILD
index af2a6a148a74..f96ea7213b7d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,14 +5,11 @@
pkgname='deluge1'
_basename="${pkgname%1}"
pkgver=1.3.15
-pkgrel=11
+pkgrel=12
pkgdesc='BitTorrent client with multiple interfaces, using a client/server model (legacy 1.3.x version)'
arch=('any')
url='https://deluge-torrent.org/'
license=('GPL3')
-depends=(
- 'python2'
-)
makedepends=(
'intltool'
'python2-setuptools'
@@ -56,11 +53,10 @@ prepare() {
cd "${_tarname}"
patch --verbose -p1 -i '../prefdialog.patch'
- echo 'Changing hashbangs in *.py files to refer to python2'
- sed -e '1s|#![ ]*/usr/bin/python[^2]\?|#!/usr/bin/python2|' \
- -e '1s|#![ ]*/usr/bin/env python[^2]\?|#!/usr/bin/env python2|' \
- -e '1s|#![ ]*/bin/env python[^2]\?|#!/usr/bin/env python2|' \
+ printf "Changing hashbangs in *.py files to refer to 'python2'... "
+ sed -e '1s|#![ ]*/[a-zA-Z0-9./_ ]*python.*|#!/usr/bin/env python2|' \
-i $(find . -name '*.py')
+ echo "done"
echo "Disabling 'get_libtorrent.sh': don't try to download libtorrent from SVN"
sed -e '5s|^$|exit 127|' \
@@ -75,6 +71,7 @@ build() {
package() {
depends=(
'hicolor-icon-theme'
+ 'python2'
'python2-chardet'
'python2-pyopenssl'
'python2-pyxdg'