summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-26 20:55:34 +0200
committerMarcell Meszaros2022-06-26 21:06:06 +0200
commit4a240a484e56155ab86e18cc3c9bafa4e80d8d02 (patch)
treead00a45c1396544f88b7879216a44c4493a37253
parentfd402ddbd10e56a854fa21cea6f5b2e98fa3b1d6 (diff)
downloadaur-4a240a484e56155ab86e18cc3c9bafa4e80d8d02.tar.gz
refactor: formatting cleanup
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD110
2 files changed, 60 insertions, 52 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d28f78f6d278..b972cd9c04a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,5 +1,5 @@
pkgbase = deluge1
- pkgdesc = A BitTorrent client with multiple interfaces in a client/server model (legacy 1.3.x version)
+ pkgdesc = BitTorrent client with multiple interfaces, using a client/server model (legacy 1.3.x version)
pkgver = 1.3.15
pkgrel = 9
url = https://deluge-torrent.org/
diff --git a/PKGBUILD b/PKGBUILD
index b288d85006b4..361bcc951b7e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,75 +2,83 @@
# Contributor: Joe Bashe <joe@bashe.joe>
# Contributor: Kim Scarborough <kim@scarborough.kim>
-pkgname=deluge1
+pkgname='deluge1'
pkgver=1.3.15
pkgrel=9
-pkgdesc='A BitTorrent client with multiple interfaces in a client/server model (legacy 1.3.x version)'
+pkgdesc='BitTorrent client with multiple interfaces, using a client/server model (legacy 1.3.x version)'
arch=('any')
url='https://deluge-torrent.org/'
license=('GPL3')
-makedepends=('intltool'
- 'libtorrent-rasterbar')
-depends=('python2'
- 'python2-attrs'
- 'python2-constantly'
- 'python2-gobject2'
- 'python2-pyxdg-git'
- 'python2-twisted-git'
- 'python2-incremental-git'
- 'python2-zope-interface-git'
- 'pygtk'
- 'desktop-file-utils'
- 'hicolor-icon-theme')
-optdepends=('python2-service-identity'
- 'libtorrent-rasterbar: required for daemon'
- 'pygtk: required for GTK client'
- 'xdg-utils: required for GTK client'
- 'python2-xdg: required for GTK client'
- 'python2-notify: optional for GTK client'
- 'python2-pygame: optional for GTK client'
- 'python2-libappindicator: optional for GTK client'
- 'python2-mako: required for web client')
+depends=(
+ 'python2'
+ 'python2-attrs'
+ 'python2-constantly'
+ 'python2-gobject2'
+ 'python2-pyxdg-git'
+ 'python2-twisted-git'
+ 'python2-incremental-git'
+ 'python2-zope-interface-git'
+ 'pygtk'
+ 'desktop-file-utils'
+ 'hicolor-icon-theme'
+)
+makedepends=(
+ 'intltool'
+ 'libtorrent-rasterbar'
+)
+optdepends=(
+ 'python2-service-identity'
+ 'libtorrent-rasterbar: required for daemon'
+ 'pygtk: required for GTK client'
+ 'xdg-utils: required for GTK client'
+ 'python2-xdg: required for GTK client'
+ 'python2-notify: optional for GTK client'
+ 'python2-pygame: optional for GTK client'
+ 'python2-libappindicator: optional for GTK client'
+ 'python2-mako: required for web client'
+)
provides=('deluge')
-conflicts=('deluge'
- 'deluge-git'
- 'deluge-stable-git')
+conflicts=(
+ 'deluge'
+ 'deluge-git'
+ 'deluge-stable-git'
+)
backup=('etc/conf.d/deluged')
# ftp.osuosl.org is supposedly the source, but the mirrors have this in a different place than the master.
# Using the master's URL until they figure it out.
source=('https://ftp-osl.osuosl.org/pub/deluge/source/1.3/deluge-1.3.15.tar.xz'
- deluged.service
- deluged.environment
- deluge-web.service
- prefdialog.patch)
+ 'deluged.service'
+ 'deluged.environment'
+ 'deluge-web.service'
+ 'prefdialog.patch')
sha256sums=('a96405140e3cbc569e6e056165e289a5e9ec66e036c327f3912c73d049ccf92c'
- '74f05cf43eae69f8ee8d257443ecdc0b0bbcc82cfb1bdb926ffe0a191164d699'
- '70f5e700570e5286f785a4bd23c23d39ae72c5662d76da9354ace46e8f6e28fd'
- '5d434c265d69773942134c143598fa2aa413989097cc30c007310801270f8b87'
- 'b4c397cc4ffede983554331c2b31e40feadda3a03e2ee377c3892c88b096b564')
+ '74f05cf43eae69f8ee8d257443ecdc0b0bbcc82cfb1bdb926ffe0a191164d699'
+ '70f5e700570e5286f785a4bd23c23d39ae72c5662d76da9354ace46e8f6e28fd'
+ '5d434c265d69773942134c143598fa2aa413989097cc30c007310801270f8b87'
+ 'b4c397cc4ffede983554331c2b31e40feadda3a03e2ee377c3892c88b096b564')
prepare() {
- cd "${srcdir}/deluge-${pkgver}"
- patch -p1 -i "${srcdir}"/prefdialog.patch
+ cd "${srcdir}/deluge-${pkgver}"
+ patch -p1 -i "${srcdir}"/prefdialog.patch
}
build() {
- cd "${srcdir}/deluge-${pkgver}"
- python2 setup.py build
+ cd "${srcdir}/deluge-${pkgver}"
+ python2 setup.py build
}
package() {
- cd "${srcdir}/deluge-${pkgver}"
- python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
- # Quick fix to keep namcap from thinking we need Python 3
- sed -i -e '1s@python@python2@' "${pkgdir}/usr/lib/python2.7/site-packages/deluge/ui/Win32IconImagePlugin.py"
- cd "${srcdir}"
- install -Dm0644 deluged.service "${pkgdir}/usr/lib/systemd/system/deluged.service"
- install -m0644 deluge-web.service "${pkgdir}/usr/lib/systemd/system/"
- install -Dm0644 deluged.environment "${pkgdir}/etc/conf.d/deluged"
+ cd "${srcdir}/deluge-${pkgver}"
+ python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ # Quick fix to keep namcap from thinking we need Python 3
+ sed -i -e '1s@python@python2@' "${pkgdir}/usr/lib/python2.7/site-packages/deluge/ui/Win32IconImagePlugin.py"
+ cd "${srcdir}"
+ install -Dm0644 deluged.service "${pkgdir}/usr/lib/systemd/system/deluged.service"
+ install -m0644 deluge-web.service "${pkgdir}/usr/lib/systemd/system/"
+ install -Dm0644 deluged.environment "${pkgdir}/etc/conf.d/deluged"
- echo 'u deluge - "Deluge BitTorrent daemon" /srv/deluge' |
- install -Dm644 /dev/stdin "${pkgdir}/usr/lib/sysusers.d/deluge.conf"
- echo 'd /srv/deluge 0770 deluge deluge' |
- install -Dm644 /dev/stdin "${pkgdir}/usr/lib/tmpfiles.d/$pkgname.conf"
+ echo 'u deluge - "Deluge BitTorrent daemon" /srv/deluge' |
+ install -Dm644 /dev/stdin "${pkgdir}/usr/lib/sysusers.d/deluge.conf"
+ echo 'd /srv/deluge 0770 deluge deluge' |
+ install -Dm644 /dev/stdin "${pkgdir}/usr/lib/tmpfiles.d/$pkgname.conf"
}