summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcell Meszaros2022-06-26 22:25:40 +0200
committerMarcell Meszaros2022-06-26 22:25:40 +0200
commit60c94726dccd32c62cfbf1ca9be6fe9fc5ba5cdf (patch)
treee9fdfea193e94ad37641307a26c0ec4a3d01a1d9
parent7d7655e54a617925691138b6e11a7193b373043e (diff)
downloadaur-60c94726dccd32c62cfbf1ca9be6fe9fc5ba5cdf.tar.gz
refactor: reduce make-time dependencies to the minimum
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD20
2 files changed, 17 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ef16f5a3b69d..253c53772d21 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,19 +6,11 @@ pkgbase = deluge1
arch = any
license = GPL3
makedepends = intltool
- makedepends = librsvg
- makedepends = pygtk
- makedepends = python2-mako
+ makedepends = libtorrent-rasterbar<=1:1.2.10-4
makedepends = python2-setuptools
- makedepends = xdg-utils
- depends = hicolor-icon-theme
- depends = libtorrent-rasterbar<=1:1.2.10-4
depends = python2
- depends = python2-chardet
- depends = python2-pyopenssl
- depends = python2-pyxdg
- depends = python2-twisted
optdepends = python2-geoip: for peer IP geolocation
+ optdepends = libtorrent-rasterbar<=1:1.2.10-4: for the daemon
optdepends = python2-notify: notifications for GTK client
optdepends = python2-pygame: audible notifications for GTK client
optdepends = python2-libappindicator: appindicator notifications for GTK client
@@ -45,3 +37,8 @@ pkgbase = deluge1
sha256sums = b4c397cc4ffede983554331c2b31e40feadda3a03e2ee377c3892c88b096b564
pkgname = deluge1
+ depends = hicolor-icon-theme
+ depends = python2-chardet
+ depends = python2-pyopenssl
+ depends = python2-pyxdg
+ depends = python2-twisted
diff --git a/PKGBUILD b/PKGBUILD
index d4cd990b0e9b..c186e69572c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -11,24 +11,16 @@ arch=('any')
url='https://deluge-torrent.org/'
license=('GPL3')
depends=(
- 'hicolor-icon-theme'
- 'libtorrent-rasterbar<=1:1.2.10-4'
'python2'
- 'python2-chardet'
- 'python2-pyopenssl'
- 'python2-pyxdg'
- 'python2-twisted'
)
makedepends=(
'intltool'
- 'librsvg'
- 'pygtk'
- 'python2-mako'
+ 'libtorrent-rasterbar<=1:1.2.10-4'
'python2-setuptools'
- 'xdg-utils'
)
optdepends=(
'python2-geoip: for peer IP geolocation'
+ 'libtorrent-rasterbar<=1:1.2.10-4: for the daemon'
'python2-notify: notifications for GTK client'
'python2-pygame: audible notifications for GTK client'
'python2-libappindicator: appindicator notifications for GTK client'
@@ -79,6 +71,14 @@ build() {
}
package() {
+ depends=(
+ 'hicolor-icon-theme'
+ 'python2-chardet'
+ 'python2-pyopenssl'
+ 'python2-pyxdg'
+ 'python2-twisted'
+ )
+
cd "${_tarname}"
python2 setup.py install --prefix='/usr' --root="${pkgdir}" --optimize=1 --skip-build