summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKim Scarborough2019-07-24 06:07:48 -0500
committerKim Scarborough2019-07-24 06:07:48 -0500
commit62d7eadc679a6dec9e55de6bc481aedf200309fd (patch)
tree89f3bae00df95438d536fcd1dbb6c18dd3a518c7
parent324e0d5ed9b656c36b46f10e1e41a1628898e347 (diff)
downloadaur-62d7eadc679a6dec9e55de6bc481aedf200309fd.tar.gz
Better fix for namcap issue
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
2 files changed, 4 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e0e619c35433..544c5a98f7f9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = deluge1
pkgdesc = A BitTorrent client with multiple interfaces in a client/server model (legacy 1.3.x version)
pkgver = 1.3.15
- pkgrel = 2
+ pkgrel = 3
url = https://deluge-torrent.org/
arch = any
license = GPL3
diff --git a/PKGBUILD b/PKGBUILD
index c398691aa671..a034d5d11c01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kim Scarborough <kim@scarborough.kim>
pkgname=deluge1
pkgver=1.3.15
-pkgrel=2
+pkgrel=3
pkgdesc='A BitTorrent client with multiple interfaces in a client/server model (legacy 1.3.x version)'
arch=('any')
url='https://deluge-torrent.org/'
@@ -47,6 +47,8 @@ build() {
package() {
cd "${srcdir}/deluge-${pkgver}"
python2 setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
+ # Quick fix to keep namcap from thinking we need Python 3
+ sed -i -e '1s@python@python2@' "${pkgdir}/usr/lib/python2.7/site-packages/deluge/ui/Win32IconImagePlugin.py"
cd "${srcdir}"
install -Dm0644 deluged.service "${pkgdir}/usr/lib/systemd/system/deluged.service"
install -m0644 deluge-web.service "${pkgdir}/usr/lib/systemd/system/"
@@ -56,7 +58,4 @@ package() {
install -Dm644 /dev/stdin "${pkgdir}/usr/lib/sysusers.d/deluge.conf"
echo 'd /srv/deluge 0770 deluge deluge' |
install -Dm644 /dev/stdin "${pkgdir}/usr/lib/tmpfiles.d/$pkgname.conf"
-
- # Remove unneeded file to keep namcap from thinking we need Python 3
- rm "${pkgdir}/usr/lib/python2.7/site-packages/deluge/ui/Win32IconImagePlugin.py"
}