summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordement6d2022-06-20 21:06:38 +0200
committerdement6d2022-06-20 21:06:38 +0200
commit7b5464dd21baa90b91a7f8d33207540e8ec8e359 (patch)
tree19a7ca5e99e472aeb7e182c35126c44a713f7ede
downloadaur-7b5464dd21baa90b91a7f8d33207540e8ec8e359.tar.gz
init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD27
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..93e7b389ff02
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = demilis
+ pkgdesc = TCP listener capable of accepting multiple connections
+ pkgver = 1.1.0
+ pkgrel = 1
+ url = https://github.com/dement6d/demilis
+ arch = arm64
+ arch = x86_64
+ license = GPL3
+ makedepends = dotnet-sdk
+ provides = demilis
+ options = !strip
+ source = git+https://github.com/dement6d/demilis
+ md5sums = SKIP
+
+pkgname = demilis
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8de91487379a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: demented <dev@snipesharp.xyz>
+pkgname=demilis
+pkgver=1.1.0
+pkgrel=1
+pkgdesc="TCP listener capable of accepting multiple connections"
+arch=('arm64' 'x86_64')
+url="https://github.com/dement6d/demilis"
+license=('GPL3')
+depends=()
+options=("!strip")
+makedepends=(dotnet-sdk)
+provides=(demilis)
+source=("git+$url")
+md5sums=('SKIP')
+
+pkgver() {
+ cd $pkgname
+ printf "1.1.0.r%s" "$(git rev-list --count HEAD)"
+}
+
+package() {
+ cd $pkgname/src
+ mkdir -p $pkgdir/usr/bin
+ [ "$CARCH" = "x86_64" ] && dotnet publish -c Release -r linux-x64 -p:PublishSingleFile=true --sc -o $pkgdir/usr/bin
+ [ "$CARCH" = "arm64" ] && dotnet publish -c Release -r linux-arm64 -p:PublishSingleFile=true --sc -o $pkgdir/usr/bin
+ rm $pkgdir/usr/bin/$pkgname.pdb
+}