summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhawkeye1164772021-01-23 22:45:04 +0100
committerhawkeye1164772021-01-23 22:45:04 +0100
commit80fd2cb9404700ab7b09b58bd6f4adf4bb224720 (patch)
treea1e37fae2934c4d744b4058d71f434074d096738
downloadaur-80fd2cb9404700ab7b09b58bd6f4adf4bb224720.tar.gz
First
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2eb018bd2b73
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = demoneditor-bin
+ pkgdesc = Enigma2 channel and satellite list editor.
+ pkgver = 1.0.4
+ pkgrel = 1
+ url = https://dyefremov.github.io/DemonEditor/
+ arch = any
+ license = MIT
+ depends = python>=3.5.2
+ depends = gtk3>=3.16
+ depends = python-gobject
+ source = https://github.com/DYefremov/DemonEditor/releases/download/1.0.4-b1/DemonEditor-1.0.4-Beta.deb
+ source = https://raw.githubusercontent.com/DYefremov/DemonEditor/master/LICENSE
+ sha256sums = 86ac1fc80ab720d1cfeb79dfd5976471d95197bc65d9866509628bae07149b1d
+ sha256sums = e5ee10c0bbb35a6697660aca48d985ece986846aae9c81657642461b91402717
+
+pkgname = demoneditor-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fd8cf152ac35
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: hawkeye116477 <hawkeye116477 at gmail.com>
+_pkgname=DemonEditor
+pkgname=demoneditor-bin
+pkgver=1.0.4
+pkgrel=1
+pkgdesc="Enigma2 channel and satellite list editor."
+url="https://dyefremov.github.io/DemonEditor/"
+license=('MIT')
+depends=('python>=3.5.2' 'gtk3>=3.16' 'python-gobject')
+arch=('any')
+source=(
+ "https://github.com/DYefremov/$_pkgname/releases/download/$pkgver-b$pkgrel/$_pkgname-$pkgver-Beta.deb"
+ "https://raw.githubusercontent.com/DYefremov/DemonEditor/master/LICENSE"
+)
+sha256sums=('86ac1fc80ab720d1cfeb79dfd5976471d95197bc65d9866509628bae07149b1d'
+ 'e5ee10c0bbb35a6697660aca48d985ece986846aae9c81657642461b91402717')
+
+prepare() {
+ tar -xf data.tar.xz
+}
+
+package()
+{
+ cd "$srcdir"
+ cp -R "$srcdir"/usr "$pkgdir"/
+ install -Dm644 "$srcdir"/LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+}