summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authornot_anonymous2015-07-05 18:04:07 -0600
committernot_anonymous2015-07-05 18:04:07 -0600
commitfbdc234b331b8eebd567e6dd74b1c6ae53e7df9a (patch)
tree9a49bd0db6cc10804f5402050e078a235425884c
downloadaur-fbdc234b331b8eebd567e6dd74b1c6ae53e7df9a.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--Changelog31
-rw-r--r--PKGBUILD39
3 files changed, 88 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9c972f6bd38e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = demorse
+ pkgdesc = console application for decoding Morse code signals into text.
+ pkgver = 1.2
+ pkgrel = 3
+ url = http://www.qsl.net/5b4az/pkg/morse/demorse/demorse.html
+ changelog = Changelog
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = autoconf
+ makedepends = automake
+ depends = alsa-lib
+ source = http://www.qsl.net/5b4az/pkg/morse/demorse/demorse-1.2.tar.bz2
+ md5sums = d4800b759ef4c8ffb6e73d173bcd563b
+ sha256sums = 48228b121f4df3bcd735a7c60871d9bea1c7f066da78c6f74e28694b8300a4ab
+
+pkgname = demorse
+
diff --git a/Changelog b/Changelog
new file mode 100644
index 000000000000..87a2579d3cce
--- /dev/null
+++ b/Changelog
@@ -0,0 +1,31 @@
+2015-02-12 not_anonymous
+
+ 1.2-3
+ * added # Original Submitter/Submission as this credit was not extent
+
+2015-01-24 not_anonymous
+
+ 1.2-2
+ * added prepare() as per author's manual
+ * added makedepends() v/v above change
+
+2014-07-27 Lex Black
+
+ 1.2-1:
+ * update to latest version
+ * changed dl location. Official page is down and was mirrored from qsl.net
+
+2013-04-28 Mariusz Libera <mariusz.libera@gmail.com>
+
+ 1.1-1:
+ * new upstream release
+ * removed Makefile patch - upstream switched to autotools
+
+ 1.0-1:
+ * new maintainer
+ * new upstream release
+ * added Changelog
+ * added README file
+ * added alsa-lib dependency
+ * corrected CFLAGS
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bc98fdcbc69
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: not_anonymous <nmlibertarian@gmail.com>
+# Contributor: Lex Black <autumn-wind at web dot de>
+# Contributor: Mariusz Libera <mariusz.libera@gmail.com>
+# Contributor: Bennett Goble <nivardus at gmail dot com>
+# Original Submission: Bob Finch <w9ya@qrparci.net>
+
+pkgname=demorse
+pkgver=1.2
+pkgrel=3
+pkgdesc="console application for decoding Morse code signals into text."
+arch=('i686' 'x86_64')
+url="http://www.qsl.net/5b4az/pkg/morse/demorse/demorse.html"
+license=('GPL3')
+depends=('alsa-lib')
+makedepends=('autoconf' 'automake')
+changelog=Changelog
+source=("http://www.qsl.net/5b4az/pkg/morse/${pkgname}/${pkgname}-${pkgver}.tar.bz2")
+
+prepare() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="$pkgdir" install
+
+ # documentation
+ install -dm755 "${pkgdir}/usr/share/doc/${pkgname}"
+ install -m644 README doc/* "${pkgdir}/usr/share/doc/${pkgname}"
+}
+md5sums=('d4800b759ef4c8ffb6e73d173bcd563b')
+sha256sums=('48228b121f4df3bcd735a7c60871d9bea1c7f066da78c6f74e28694b8300a4ab')