summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMattia Borda2023-05-27 13:29:27 +0200
committerMattia Borda2023-05-27 13:29:27 +0200
commitf6245494edfe94ebd14f8902692ee72f8db7238d (patch)
tree7869a3d51856f296ff6670bc8245478f9847ae09
parenteb5deecb12cd68c066e7fef4373f79d794356a17 (diff)
downloadaur-f6245494edfe94ebd14f8902692ee72f8db7238d.tar.gz
Update to 2023.5.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD15
2 files changed, 13 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f0f0eea334a0..4ab2bd43653c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = denaro
pkgdesc = A personal finance manager
- pkgver = 2023.4.1
+ pkgver = 2023.5.0
pkgrel = 1
url = https://github.com/NickvisionApps/denaro
arch = aarch64
@@ -11,10 +11,9 @@ pkgbase = denaro
makedepends = blueprint-compiler
makedepends = dotnet-sdk>=7
makedepends = git
- makedepends = just
depends = dotnet-runtime>=7
depends = libadwaita
- source = git+https://github.com/NickvisionApps/denaro#tag=2023.4.1
+ source = git+https://github.com/NickvisionApps/denaro#tag=2023.5.0
b2sums = SKIP
pkgname = denaro
diff --git a/PKGBUILD b/PKGBUILD
index 4ee42c7b5bb8..7105768eddda 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,21 +1,28 @@
# Maintainer: Mattia Borda <mattiagiovanni.borda@icloud.com>
pkgname=denaro
-pkgver=2023.4.1
+pkgver=2023.5.0
pkgrel=1
pkgdesc="A personal finance manager"
arch=(aarch64 armv7h x86_64 i686)
url=https://github.com/NickvisionApps/$pkgname
license=(GPL3)
depends=('dotnet-runtime>=7' libadwaita)
-makedepends=(blueprint-compiler 'dotnet-sdk>=7' git just)
+makedepends=(blueprint-compiler 'dotnet-sdk>=7' git)
source=(git+$url#tag=$pkgver)
b2sums=('SKIP')
+prepare() {
+ cd $pkgname
+ dotnet tool restore
+}
+
build() {
- just $pkgname/NickvisionMoney.GNOME/ publish /usr
+ cd $pkgname
+ dotnet cake --target=Publish --prefix=/usr --ui=gnome
}
package() {
- just $pkgname/NickvisionMoney.GNOME/ install "$pkgdir"
+ cd $pkgname
+ dotnet cake --target=Install --destdir="$pkgdir"
}