summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoshless2021-03-03 14:38:34 +0100
committerStefan Tatschner2021-03-03 19:41:22 +0100
commite8cc052e05c1d4e876479b7c52b366d487ff5877 (patch)
tree7ffd06ef0d14ceb7f2f409d838310891d337fa52
parent1afd298aac2eb77cdee2f6563adca77c108d67d9 (diff)
downloadaur-e8cc052e05c1d4e876479b7c52b366d487ff5877.tar.gz
update dendrite to 0.3.11
also update sample config and add log folders
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD10
-rw-r--r--config-sample.yaml56
-rw-r--r--dendrite.service1
-rw-r--r--tmpfiles-dendrite.conf1
5 files changed, 53 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1d727deb9cd4..696edeab6f2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,21 +1,21 @@
pkgbase = dendrite
pkgdesc = A second-generation Matrix homeserver written in Go
- pkgver = 0.3.8
+ pkgver = 0.3.11
pkgrel = 1
url = https://github.com/matrix-org/dendrite
arch = x86_64
license = Apache
makedepends = go
- source = https://github.com/matrix-org/dendrite/archive/v0.3.8/dendrite-v0.3.8.tar.gz
+ source = https://github.com/matrix-org/dendrite/archive/v0.3.11/dendrite-v0.3.11.tar.gz
source = config-sample.yaml
source = dendrite.sysusers
source = tmpfiles-dendrite.conf
source = dendrite.service
- sha256sums = d73262401661bb8987d912a0ea16d71435c709d20f08344a594b000b6e080869
- sha256sums = 198f7f29dae00f89314672e64c9f264b5686bb8bcc6314df4ec54795318c07e6
+ sha256sums = e473fa629af175ff0dda29ad93c9d7c1a3f35d216b2df6b19aab978856e58e4a
+ sha256sums = 6a322c0fe6accc645b51dc0e7ebff1f7fae263b420a7dcd9eec0ddb936155b76
sha256sums = aba328d7a7244e82f866f9d0ead0a53e79e1590b9c449ad6d18ff2659cb5e035
- sha256sums = c8305641995461deef4dd84c5886e1cd84a0b2b11451f77d0d48076e8b5b0bfe
- sha256sums = db77b1e6c29e291749e0632d490ac3bbdcc4e4eee6de53fb7ad498944e7e2da8
+ sha256sums = 7d3b8e046581c70857d452eb6569ea239989c7a47f818c184773b52df8a712dc
+ sha256sums = 562a89c61d4f54a2558024f755497a3a59b1c85e236924131fdf58724ed25f3f
pkgname = dendrite
diff --git a/PKGBUILD b/PKGBUILD
index 6ae64ae8710d..90c623f33212 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
pkgname=dendrite
-pkgver=0.3.8
+pkgver=0.3.11
pkgrel=1
pkgdesc="A second-generation Matrix homeserver written in Go"
arch=('x86_64')
@@ -13,11 +13,11 @@ source=("https://github.com/matrix-org/dendrite/archive/v$pkgver/dendrite-v$pkgv
"dendrite.sysusers"
"tmpfiles-dendrite.conf"
"dendrite.service")
-sha256sums=('d73262401661bb8987d912a0ea16d71435c709d20f08344a594b000b6e080869'
- '198f7f29dae00f89314672e64c9f264b5686bb8bcc6314df4ec54795318c07e6'
+sha256sums=('e473fa629af175ff0dda29ad93c9d7c1a3f35d216b2df6b19aab978856e58e4a'
+ '6a322c0fe6accc645b51dc0e7ebff1f7fae263b420a7dcd9eec0ddb936155b76'
'aba328d7a7244e82f866f9d0ead0a53e79e1590b9c449ad6d18ff2659cb5e035'
- 'c8305641995461deef4dd84c5886e1cd84a0b2b11451f77d0d48076e8b5b0bfe'
- 'db77b1e6c29e291749e0632d490ac3bbdcc4e4eee6de53fb7ad498944e7e2da8')
+ '7d3b8e046581c70857d452eb6569ea239989c7a47f818c184773b52df8a712dc'
+ '562a89c61d4f54a2558024f755497a3a59b1c85e236924131fdf58724ed25f3f')
build() {
cd "$pkgname-$pkgver"
diff --git a/config-sample.yaml b/config-sample.yaml
index 9898094b9e0e..a3d1065d4297 100644
--- a/config-sample.yaml
+++ b/config-sample.yaml
@@ -6,7 +6,7 @@
#
# At a minimum, to get started, you will need to update the settings in the
# "global" section for your deployment, and you will need to check that the
-# database "connection_string" line in each component section is correct.
+# database "connection_string" line in each component section is correct.
#
# Each component with a "database" section can accept the following formats
# for "connection_string":
@@ -21,13 +21,13 @@
# small number of users and likely will perform worse still with a higher volume
# of users.
#
-# The "max_open_conns" and "max_idle_conns" settings configure the maximum
+# The "max_open_conns" and "max_idle_conns" settings configure the maximum
# number of open/idle database connections. The value 0 will use the database
# engine default, and a negative value will use unlimited connections. The
# "conn_max_lifetime" option controls the maximum length of time a database
# connection can be idle in seconds - a negative value is unlimited.
-# The version of the configuration file.
+# The version of the configuration file.
version: 1
# Global Matrix configuration. This configuration applies to all components.
@@ -89,7 +89,7 @@ global:
# Naffka database options. Not required when using Kafka.
naffka_database:
connection_string: file:naffka.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -103,6 +103,17 @@ global:
username: metrics
password: metrics
+ # DNS cache options. The DNS cache may reduce the load on DNS servers
+ # if there is no local caching resolver available for use.
+ dns_cache:
+ # Whether or not the DNS cache is enabled.
+ enabled: false
+
+ # Maximum number of entries to hold in the DNS cache, and
+ # for how long those items should be considered valid in seconds.
+ cache_size: 256
+ cache_lifetime: 300
+
# Configuration for the Appservice API.
app_service_api:
internal_api:
@@ -110,7 +121,7 @@ app_service_api:
connect: http://localhost:7777
database:
connection_string: file:appservice.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -136,13 +147,13 @@ client_api:
# Whether to require reCAPTCHA for registration.
enable_registration_captcha: false
- # Settings for ReCAPTCHA.
+ # Settings for ReCAPTCHA.
recaptcha_public_key: ""
recaptcha_private_key: ""
recaptcha_bypass_secret: ""
recaptcha_siteverify_api: ""
- # TURN server information that this homeserver should send to clients.
+ # TURN server information that this homeserver should send to clients.
turn:
turn_user_lifetime: ""
turn_uris: []
@@ -151,7 +162,7 @@ client_api:
turn_password: ""
# Settings for rate-limited endpoints. Rate limiting will kick in after the
- # threshold number of "slots" have been taken by requests from a specific
+ # threshold number of "slots" have been taken by requests from a specific
# host. Each "slot" will be released after the cooloff time in milliseconds.
rate_limiting:
enabled: true
@@ -185,7 +196,7 @@ federation_sender:
connect: http://localhost:7775
database:
connection_string: file:federationsender.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -211,7 +222,7 @@ key_server:
connect: http://localhost:7779
database:
connection_string: file:keyserver.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -224,7 +235,7 @@ media_api:
listen: http://[::]:8074
database:
connection_string: file:mediaapi.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -253,6 +264,19 @@ media_api:
height: 480
method: scale
+# Configuration for experimental MSC's
+mscs:
+ # A list of enabled MSC's
+ # Currently valid values are:
+ # - msc2836 (Threading, see https://github.com/matrix-org/matrix-doc/pull/2836)
+ # - msc2946 (Spaces Summary, see https://github.com/matrix-org/matrix-doc/pull/2946)
+ mscs: []
+ database:
+ connection_string: file:mscs.db
+ max_open_conns: 10
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
# Configuration for the Room Server.
room_server:
internal_api:
@@ -260,7 +284,7 @@ room_server:
connect: http://localhost:7770
database:
connection_string: file:roomserver.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -271,7 +295,7 @@ signing_key_server:
connect: http://localhost:7780
database:
connection_string: file:signingkeyserver.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -300,7 +324,7 @@ sync_api:
listen: http://[::]:8073
database:
connection_string: file:syncapi.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
@@ -316,12 +340,12 @@ user_api:
connect: http://localhost:7781
account_database:
connection_string: file:userapi_accounts.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
device_database:
connection_string: file:userapi_devices.db
- max_open_conns: 100
+ max_open_conns: 10
max_idle_conns: 2
conn_max_lifetime: -1
diff --git a/dendrite.service b/dendrite.service
index 1a60f5afd4ea..a65833181595 100644
--- a/dendrite.service
+++ b/dendrite.service
@@ -8,6 +8,7 @@ Wants=postgresql.service
User=dendrite
Group=dendrite
ExecStart=/usr/bin/dendrite --config=/etc/dendrite/config.yaml
+WorkingDirectory=/var/lib/dendrite/
[Install]
WantedBy=multi-user.target
diff --git a/tmpfiles-dendrite.conf b/tmpfiles-dendrite.conf
index f6defcddeb7b..056ecb283a81 100644
--- a/tmpfiles-dendrite.conf
+++ b/tmpfiles-dendrite.conf
@@ -1 +1,2 @@
d /var/lib/dendrite 0700 dendrite dendrite -
+d /var/log/dendrite 0700 dendrite dendrite -