summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStefan Tatschner2020-12-14 14:54:23 +0100
committerStefan Tatschner2020-12-14 14:54:23 +0100
commitf74d24a26195b51a023d274a93dc5e67f4819879 (patch)
tree8f690c93cd6c6bebbe6d795539e8927ac80cf34d
parentf0584b3fba13542cf1feaf0ca86821cc56610d68 (diff)
downloadaur-f74d24a26195b51a023d274a93dc5e67f4819879.tar.gz
upgpkg: dendrite 0.3.3-1
upstream release
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD19
-rw-r--r--config-sample.yaml350
-rw-r--r--dendrite.sysusers1
-rw-r--r--tmpfiles-dendrite.conf1
5 files changed, 375 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 343d03dbd470..91926fccd4f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,20 @@
pkgbase = dendrite
pkgdesc = A second-generation Matrix homeserver written in Go
- pkgver = 0.3.2
+ pkgver = 0.3.3
pkgrel = 1
url = https://github.com/matrix-org/dendrite
arch = x86_64
license = Apache
makedepends = go
- source = https://github.com/matrix-org/dendrite/archive/v0.3.2/dendrite-v0.3.2.tar.gz
+ source = https://github.com/matrix-org/dendrite/archive/v0.3.3/dendrite-v0.3.3.tar.gz
+ source = config-sample.yaml
+ source = dendrite.sysusers
+ source = tmpfiles-dendrite.conf
source = dendrite.service
- sha256sums = 2698ca818651c1c9b2d083df2ff9e9701209314630f406ac613f0bb0f682f92d
+ sha256sums = d67685a0403d87d5d70cd8380cd7a2462e3724f14d931e9ad5ab45bc976795ef
+ sha256sums = 198f7f29dae00f89314672e64c9f264b5686bb8bcc6314df4ec54795318c07e6
+ sha256sums = aba328d7a7244e82f866f9d0ead0a53e79e1590b9c449ad6d18ff2659cb5e035
+ sha256sums = c8305641995461deef4dd84c5886e1cd84a0b2b11451f77d0d48076e8b5b0bfe
sha256sums = 5957e293152b982aacb2fbb7f29e889f7d174dd6a718b28ee69a1b1d368ff125
pkgname = dendrite
diff --git a/PKGBUILD b/PKGBUILD
index febd7442e570..dd4054aee931 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Stefan Tatschner <stefan@rumpelsepp.org>
pkgname=dendrite
-pkgver=0.3.2
+pkgver=0.3.3
pkgrel=1
pkgdesc="A second-generation Matrix homeserver written in Go"
arch=('x86_64')
@@ -9,8 +9,14 @@ url='https://github.com/matrix-org/dendrite'
license=('Apache')
makedepends=('go')
source=("https://github.com/matrix-org/dendrite/archive/v$pkgver/dendrite-v$pkgver.tar.gz"
+ "config-sample.yaml"
+ "dendrite.sysusers"
+ "tmpfiles-dendrite.conf"
"dendrite.service")
sha256sums=('2698ca818651c1c9b2d083df2ff9e9701209314630f406ac613f0bb0f682f92d'
+ 'a0ce0d2166167515a1406125990703e9fe49785fa0a9a5cc1f46f6f7b9b1a3b5'
+ 'aba328d7a7244e82f866f9d0ead0a53e79e1590b9c449ad6d18ff2659cb5e035'
+ 'c8305641995461deef4dd84c5886e1cd84a0b2b11451f77d0d48076e8b5b0bfe'
'5957e293152b982aacb2fbb7f29e889f7d174dd6a718b28ee69a1b1d368ff125')
build() {
@@ -37,8 +43,11 @@ check() {
package() {
cd "$pkgname-$pkgver"
- install -Dm755 ./dendrite-monolith-server "$pkgdir/usr/bin/${pkgname}"
- install -Dm755 ./generate-config "$pkgdir/usr/bin/${pkgname}-generate-config"
- install -Dm755 ./generate-keys "$pkgdir/usr/bin/${pkgname}-generate-keys"
- install -Dm755 "$srcdir/dendrite.service" "$pkgdir/usr/lib/systemd/system/${pkgname}.service"
+ install -Dm755 ./dendrite-monolith-server "${pkgdir}/usr/bin/${pkgname}"
+ install -Dm755 ./generate-config "${pkgdir}/usr/bin/${pkgname}-generate-config"
+ install -Dm755 ./generate-keys "${pkgdir}/usr/bin/${pkgname}-generate-keys"
+ install -Dm644 "${srcdir}/config-sample.yaml" "${pkgdir}/etc/dendrite/config-sample.yaml"
+ install -Dm644 "${srcdir}/dendrite.service" "${pkgdir}/usr/lib/systemd/system/${pkgname}.service"
+ install -Dm644 "${srcdir}/${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ install -Dm644 "${srcdir}/tmpfiles-${pkgname}.conf" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
}
diff --git a/config-sample.yaml b/config-sample.yaml
new file mode 100644
index 000000000000..9898094b9e0e
--- /dev/null
+++ b/config-sample.yaml
@@ -0,0 +1,350 @@
+# This is the Dendrite configuration file.
+#
+# The configuration is split up into sections - each Dendrite component has a
+# configuration section, in addition to the "global" section which applies to
+# all components.
+#
+# At a minimum, to get started, you will need to update the settings in the
+# "global" section for your deployment, and you will need to check that the
+# database "connection_string" line in each component section is correct.
+#
+# Each component with a "database" section can accept the following formats
+# for "connection_string":
+# SQLite: file:filename.db
+# file:///path/to/filename.db
+# PostgreSQL: postgresql://user:pass@hostname/database?params=...
+#
+# SQLite is embedded into Dendrite and therefore no further prerequisites are
+# needed for the database when using SQLite mode. However, performance with
+# PostgreSQL is significantly better and recommended for multi-user deployments.
+# SQLite is typically around 20-30% slower than PostgreSQL when tested with a
+# small number of users and likely will perform worse still with a higher volume
+# of users.
+#
+# The "max_open_conns" and "max_idle_conns" settings configure the maximum
+# number of open/idle database connections. The value 0 will use the database
+# engine default, and a negative value will use unlimited connections. The
+# "conn_max_lifetime" option controls the maximum length of time a database
+# connection can be idle in seconds - a negative value is unlimited.
+
+# The version of the configuration file.
+version: 1
+
+# Global Matrix configuration. This configuration applies to all components.
+global:
+ # The domain name of this homeserver.
+ server_name: localhost
+
+ # The path to the signing private key file, used to sign requests and events.
+ # Note that this is NOT the same private key as used for TLS! To generate a
+ # signing key, use "./bin/generate-keys --private-key matrix_key.pem".
+ private_key: matrix_key.pem
+
+ # The paths and expiry timestamps (as a UNIX timestamp in millisecond precision)
+ # to old signing private keys that were formerly in use on this domain. These
+ # keys will not be used for federation request or event signing, but will be
+ # provided to any other homeserver that asks when trying to verify old events.
+ # old_private_keys:
+ # - private_key: old_matrix_key.pem
+ # expired_at: 1601024554498
+
+ # How long a remote server can cache our server signing key before requesting it
+ # again. Increasing this number will reduce the number of requests made by other
+ # servers for our key but increases the period that a compromised key will be
+ # considered valid by other homeservers.
+ key_validity_period: 168h0m0s
+
+ # Lists of domains that the server will trust as identity servers to verify third
+ # party identifiers such as phone numbers and email addresses.
+ trusted_third_party_id_servers:
+ - matrix.org
+ - vector.im
+
+ # Disables federation. Dendrite will not be able to make any outbound HTTP requests
+ # to other servers and the federation API will not be exposed.
+ disable_federation: false
+
+ # Configuration for Kafka/Naffka.
+ kafka:
+ # List of Kafka broker addresses to connect to. This is not needed if using
+ # Naffka in monolith mode.
+ addresses:
+ - localhost:2181
+
+ # The prefix to use for Kafka topic names for this homeserver. Change this only if
+ # you are running more than one Dendrite homeserver on the same Kafka deployment.
+ topic_prefix: Dendrite
+
+ # Whether to use Naffka instead of Kafka. This is only available in monolith
+ # mode, but means that you can run a single-process server without requiring
+ # Kafka.
+ use_naffka: true
+
+ # The max size a Kafka message is allowed to use.
+ # You only need to change this value, if you encounter issues with too large messages.
+ # Must be less than/equal to "max.message.bytes" configured in Kafka.
+ # Defaults to 8388608 bytes.
+ # max_message_bytes: 8388608
+
+ # Naffka database options. Not required when using Kafka.
+ naffka_database:
+ connection_string: file:naffka.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+ # Configuration for Prometheus metric collection.
+ metrics:
+ # Whether or not Prometheus metrics are enabled.
+ enabled: false
+
+ # HTTP basic authentication to protect access to monitoring.
+ basic_auth:
+ username: metrics
+ password: metrics
+
+# Configuration for the Appservice API.
+app_service_api:
+ internal_api:
+ listen: http://localhost:7777
+ connect: http://localhost:7777
+ database:
+ connection_string: file:appservice.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+ # Appservice configuration files to load into this homeserver.
+ config_files: []
+
+# Configuration for the Client API.
+client_api:
+ internal_api:
+ listen: http://localhost:7771
+ connect: http://localhost:7771
+ external_api:
+ listen: http://[::]:8071
+
+ # Prevents new users from being able to register on this homeserver, except when
+ # using the registration shared secret below.
+ registration_disabled: false
+
+ # If set, allows registration by anyone who knows the shared secret, regardless of
+ # whether registration is otherwise disabled.
+ registration_shared_secret: ""
+
+ # Whether to require reCAPTCHA for registration.
+ enable_registration_captcha: false
+
+ # Settings for ReCAPTCHA.
+ recaptcha_public_key: ""
+ recaptcha_private_key: ""
+ recaptcha_bypass_secret: ""
+ recaptcha_siteverify_api: ""
+
+ # TURN server information that this homeserver should send to clients.
+ turn:
+ turn_user_lifetime: ""
+ turn_uris: []
+ turn_shared_secret: ""
+ turn_username: ""
+ turn_password: ""
+
+ # Settings for rate-limited endpoints. Rate limiting will kick in after the
+ # threshold number of "slots" have been taken by requests from a specific
+ # host. Each "slot" will be released after the cooloff time in milliseconds.
+ rate_limiting:
+ enabled: true
+ threshold: 5
+ cooloff_ms: 500
+
+# Configuration for the EDU server.
+edu_server:
+ internal_api:
+ listen: http://localhost:7778
+ connect: http://localhost:7778
+
+# Configuration for the Federation API.
+federation_api:
+ internal_api:
+ listen: http://localhost:7772
+ connect: http://localhost:7772
+ external_api:
+ listen: http://[::]:8072
+
+ # List of paths to X.509 certificates to be used by the external federation listeners.
+ # These certificates will be used to calculate the TLS fingerprints and other servers
+ # will expect the certificate to match these fingerprints. Certificates must be in PEM
+ # format.
+ federation_certificates: []
+
+# Configuration for the Federation Sender.
+federation_sender:
+ internal_api:
+ listen: http://localhost:7775
+ connect: http://localhost:7775
+ database:
+ connection_string: file:federationsender.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+ # How many times we will try to resend a failed transaction to a specific server. The
+ # backoff is 2**x seconds, so 1 = 2 seconds, 2 = 4 seconds, 3 = 8 seconds etc.
+ send_max_retries: 16
+
+ # Disable the validation of TLS certificates of remote federated homeservers. Do not
+ # enable this option in production as it presents a security risk!
+ disable_tls_validation: false
+
+ # Use the following proxy server for outbound federation traffic.
+ proxy_outbound:
+ enabled: false
+ protocol: http
+ host: localhost
+ port: 8080
+
+# Configuration for the Key Server (for end-to-end encryption).
+key_server:
+ internal_api:
+ listen: http://localhost:7779
+ connect: http://localhost:7779
+ database:
+ connection_string: file:keyserver.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+# Configuration for the Media API.
+media_api:
+ internal_api:
+ listen: http://localhost:7774
+ connect: http://localhost:7774
+ external_api:
+ listen: http://[::]:8074
+ database:
+ connection_string: file:mediaapi.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+ # Storage path for uploaded media. May be relative or absolute.
+ base_path: ./media_store
+
+ # The maximum allowed file size (in bytes) for media uploads to this homeserver
+ # (0 = unlimited).
+ max_file_size_bytes: 10485760
+
+ # Whether to dynamically generate thumbnails if needed.
+ dynamic_thumbnails: false
+
+ # The maximum number of simultaneous thumbnail generators to run.
+ max_thumbnail_generators: 10
+
+ # A list of thumbnail sizes to be generated for media content.
+ thumbnail_sizes:
+ - width: 32
+ height: 32
+ method: crop
+ - width: 96
+ height: 96
+ method: crop
+ - width: 640
+ height: 480
+ method: scale
+
+# Configuration for the Room Server.
+room_server:
+ internal_api:
+ listen: http://localhost:7770
+ connect: http://localhost:7770
+ database:
+ connection_string: file:roomserver.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+# Configuration for the Signing Key Server (for server signing keys).
+signing_key_server:
+ internal_api:
+ listen: http://localhost:7780
+ connect: http://localhost:7780
+ database:
+ connection_string: file:signingkeyserver.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+ # Perspective keyservers to use as a backup when direct key fetches fail. This may
+ # be required to satisfy key requests for servers that are no longer online when
+ # joining some rooms.
+ key_perspectives:
+ - server_name: matrix.org
+ keys:
+ - key_id: ed25519:auto
+ public_key: Noi6WqcDj0QmPxCNQqgezwTlBKrfqehY1u2FyWP9uYw
+ - key_id: ed25519:a_RXGa
+ public_key: l8Hft5qXKn1vfHrg3p4+W8gELQVo8N13JkluMfmn2sQ
+
+ # This option will control whether Dendrite will prefer to look up keys directly
+ # or whether it should try perspective servers first, using direct fetches as a
+ # last resort.
+ prefer_direct_fetch: false
+
+# Configuration for the Sync API.
+sync_api:
+ internal_api:
+ listen: http://localhost:7773
+ connect: http://localhost:7773
+ external_api:
+ listen: http://[::]:8073
+ database:
+ connection_string: file:syncapi.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+ # This option controls which HTTP header to inspect to find the real remote IP
+ # address of the client. This is likely required if Dendrite is running behind
+ # a reverse proxy server.
+ # real_ip_header: X-Real-IP
+
+# Configuration for the User API.
+user_api:
+ internal_api:
+ listen: http://localhost:7781
+ connect: http://localhost:7781
+ account_database:
+ connection_string: file:userapi_accounts.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+ device_database:
+ connection_string: file:userapi_devices.db
+ max_open_conns: 100
+ max_idle_conns: 2
+ conn_max_lifetime: -1
+
+# Configuration for Opentracing.
+# See https://github.com/matrix-org/dendrite/tree/master/docs/tracing for information on
+# how this works and how to set it up.
+tracing:
+ enabled: false
+ jaeger:
+ serviceName: ""
+ disabled: false
+ rpc_metrics: false
+ tags: []
+ sampler: null
+ reporter: null
+ headers: null
+ baggage_restrictions: null
+ throttler: null
+
+# Logging configuration, in addition to the standard logging that is sent to
+# stdout by Dendrite.
+logging:
+- type: file
+ level: info
+ params:
+ path: /var/log/dendrite
diff --git a/dendrite.sysusers b/dendrite.sysusers
new file mode 100644
index 000000000000..c339b63d2235
--- /dev/null
+++ b/dendrite.sysusers
@@ -0,0 +1 @@
+u dendrite - "Matrix Dendrite User" /var/lib/dendrite
diff --git a/tmpfiles-dendrite.conf b/tmpfiles-dendrite.conf
new file mode 100644
index 000000000000..f6defcddeb7b
--- /dev/null
+++ b/tmpfiles-dendrite.conf
@@ -0,0 +1 @@
+d /var/lib/dendrite 0700 dendrite dendrite -