summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authordatabase641282023-02-08 20:19:01 +0800
committerdatabase641282023-02-08 20:19:01 +0800
commited02e2440102882dc305cd8e1537fea530acd24e (patch)
tree2d8b8b63a89383444e17fdc68130bc227bf30f8b
parentbb5cb96f991cfdfe6408080c003f9f9d2b6930cb (diff)
downloadaur-ed02e2440102882dc305cd8e1537fea530acd24e.tar.gz
🔼 Update to v0.11.0
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD6
-rw-r--r--dendrite.install39
-rw-r--r--dendrite.tmpfiles2
4 files changed, 38 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 883850f9a8b0..906ce0600cee 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = dendrite-libvips
pkgdesc = A second-generation Matrix homeserver written in Go
- pkgver = 0.9.1
+ pkgver = 0.11.0
pkgrel = 1
url = https://github.com/matrix-org/dendrite
install = dendrite.install
@@ -12,13 +12,13 @@ pkgbase = dendrite-libvips
optdepends = postgresql: recommended database for large instances
provides = dendrite
conflicts = dendrite
- source = dendrite-0.9.1.tar.gz::https://github.com/matrix-org/dendrite/archive/v0.9.1/dendrite-v0.9.1.tar.gz
+ source = dendrite-0.11.0.tar.gz::https://github.com/matrix-org/dendrite/archive/v0.11.0/dendrite-v0.11.0.tar.gz
source = dendrite.sysusers
source = dendrite.tmpfiles
source = dendrite.service
- sha256sums = 5a65eb07b47dffefab2e8abe48cd7d37bc59e08c5163b09c63ec1d30cc808d35
+ sha256sums = d79ab86c66e6df5a310d28ef59c9207ebeb00ef694f3ec7822f06680c195922f
sha256sums = aba328d7a7244e82f866f9d0ead0a53e79e1590b9c449ad6d18ff2659cb5e035
- sha256sums = 8da956f9fcc7c6ea844cea53c823fcfa4376acf04ecd9bceb1a908a85846c90f
- sha256sums = afcaa66d826a0b56b1cfb165b05c37dc6ec5739b24e21d382edb6c7973e588ff
+ sha256sums = 620b634419e94cb09423d39ecd7edf859bf458e9d72c35be30610b37acc1e8bf
+ sha256sums = 2ce2e6fd819087bc47f4b369205afeaf0070dacf3305efcfbec5365bd11af6e7
pkgname = dendrite-libvips
diff --git a/PKGBUILD b/PKGBUILD
index 3b7407cb23c1..e675186aa871 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
_pkgname=dendrite
pkgname=$_pkgname-libvips
-pkgver=0.9.1
+pkgver=0.11.0
pkgrel=1
pkgdesc="A second-generation Matrix homeserver written in Go"
arch=('x86_64' 'aarch64')
@@ -17,9 +17,9 @@ source=("$_pkgname-$pkgver.tar.gz::https://github.com/matrix-org/$_pkgname/archi
"$_pkgname.sysusers"
"$_pkgname.tmpfiles"
"$_pkgname.service")
-sha256sums=('5a65eb07b47dffefab2e8abe48cd7d37bc59e08c5163b09c63ec1d30cc808d35'
+sha256sums=('d79ab86c66e6df5a310d28ef59c9207ebeb00ef694f3ec7822f06680c195922f'
'aba328d7a7244e82f866f9d0ead0a53e79e1590b9c449ad6d18ff2659cb5e035'
- '8da956f9fcc7c6ea844cea53c823fcfa4376acf04ecd9bceb1a908a85846c90f'
+ '620b634419e94cb09423d39ecd7edf859bf458e9d72c35be30610b37acc1e8bf'
'afcaa66d826a0b56b1cfb165b05c37dc6ec5739b24e21d382edb6c7973e588ff')
install="$_pkgname.install"
diff --git a/dendrite.install b/dendrite.install
index a14637dcf15e..ccafbc12696e 100644
--- a/dendrite.install
+++ b/dendrite.install
@@ -1,19 +1,27 @@
post_install(){
cat <<INFO
-You should now generate a new configuration either with
+Dendrite has been installed, you should now generate a new configuration and a private key files by running
- sudo cp /etc/dendrite/config-example.yaml /etc/dendrite/config.yaml
+ dendrite-generate-config --dir "/var/lib/dendrite" | sudo -u dendrite tee "/etc/dendrite/config.yaml"
+
+and then
-or
+ sudo -u dendrite dendrite-generate-keys --private-key "/var/lib/dendrite/matrix_key.pem"
+
+An example configuration file with comments can be found at
- dendrite-generate-config | sudo tee /etc/dendrite/config.yaml
+ /etc/dendrite/config-example.yaml
+
+You can start the Dentrite server by running
+
+ sudo systemctl start dendrite
INFO
}
post_upgrade(){
- # notify about breaking changes
+ # notify about breaking changes from v1 to v2
# https://wiki.archlinux.org/title/PKGBUILD#install
if [[ $1 != 0.6* ]] && [[ $2 == 0.6* ]]; then
cat <<INFO
@@ -23,14 +31,25 @@ You are advised to backup your previous configuration located at
/etc/dendrite/config.yaml
-and generate a new one either copying
+and generate a new configuration by running
- /etc/dendrite/config-example.yaml
+ dendrite-generate-config --dir "/var/lib/dendrite" | sudo -u dendrite tee "/etc/dendrite/config.yaml"
-or by running
+INFO
+ fi
- dendrite-generate-config | sudo tee /etc/dendrite/config.yaml
+ # tee cannot be used to replace the input file, mv is necessary
+ cat <<INFO
+
+Dendrite has been updated, you should now update its configuration file by running
+
+ sudo -u dendrite bash
+ cd "/var/lib/dendrite"
+ dendrite-generate-config --normalise "/etc/dendrite/config.yaml" | tee "/etc/dendrite/config.yaml.new"
+ mv "/etc/dendrite/config.yaml" "/etc/dendrite/config.yaml.bkp"
+ mv "/etc/dendrite/config.new" "/etc/dendrite/config.yaml"
+ exit
+ sudo systemctl restart dendrite
INFO
- fi
}
diff --git a/dendrite.tmpfiles b/dendrite.tmpfiles
index c1ada22e671b..ca861742f338 100644
--- a/dendrite.tmpfiles
+++ b/dendrite.tmpfiles
@@ -1,3 +1,3 @@
-d /etc/dendrite 0750 root dendrite -
+d /etc/dendrite 0750 dendrite dendrite -
d /var/lib/dendrite 0700 dendrite dendrite -
d /var/log/dendrite 0700 dendrite dendrite -