summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlilac2019-10-08 17:28:36 +0800
committerlilac2019-10-08 17:28:36 +0800
commit20b41eda1b877753329076669364afd106aca706 (patch)
tree9bdefa377d8166d3aa064cc70a288c33fbcccae2
parent7982b141f9d22cb4c1a456d089fe59c7c0aaa5e2 (diff)
downloadaur-20b41eda1b877753329076669364afd106aca706.tar.gz
update by lilac
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f17f8b7f550d..ccebab3a29e3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = deno
pkgdesc = A secure JavaScript/TypeScript runtime built with V8, Rust, and Tokio
- pkgver = 0.17.0
+ pkgver = 0.20.0
pkgrel = 1
url = https://github.com/denoland/deno
arch = i686
@@ -10,7 +10,8 @@ pkgbase = deno
makedepends = python2
makedepends = cargo
makedepends = nodejs
- source = deno-0.17.0::git+https://github.com/denoland/deno#tag=v0.17.0
+ depends = gcc-libs
+ source = deno-0.20.0::git+https://github.com/denoland/deno#tag=v0.20.0
sha512sums = SKIP
pkgname = deno
diff --git a/PKGBUILD b/PKGBUILD
index e3e5e6f22823..7921291cd732 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,38 @@
# Maintainer: Metal A-wing <1 at 233 dot email>
pkgname=deno
-pkgver=0.17.0
+pkgver=0.20.0
pkgrel=1
pkgdesc="A secure JavaScript/TypeScript runtime built with V8, Rust, and Tokio"
arch=('i686' 'x86_64')
url="https://github.com/denoland/deno"
license=('MIT')
+depends=('gcc-libs')
makedepends=('git' 'python2' 'cargo' 'nodejs')
source=("${pkgname}-${pkgver}::git+https://github.com/denoland/deno#tag=v${pkgver}")
sha512sums=('SKIP')
prepare() {
cd ${pkgname}-${pkgver}
- git submodule update --init --recursive
- mkdir -p "${srcdir}"/python2-path
- ln -sf /usr/bin/python2 "${srcdir}/python2-path/python"
- PATH="${srcdir}/python2-path:${PATH}" ./tools/setup.py
+ git submodule update --init --recursive
+ mkdir -p "${srcdir}"/python2-path
+ ln -sf /usr/bin/python2 "${srcdir}/python2-path/python"
+ PATH="${srcdir}/python2-path:${PATH}"
}
build() {
cd ${pkgname}-${pkgver}
- PATH="${srcdir}/python2-path:${PATH}" DENO_BUILD_MODE=release ./tools/build.py deno
+ cargo build --release --locked
}
check() {
cd ${pkgname}-${pkgver}
- ./target/release/deno run tests/002_hello.ts
+ ./target/release/deno run tests/002_hello.ts
}
package() {
cd ${pkgname}-${pkgver}
- install -Dm755 target/release/deno "${pkgdir}"/usr/bin/deno
- install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
+ install -Dm755 target/release/deno "${pkgdir}"/usr/bin/deno
+ install -Dm644 LICENSE "${pkgdir}"/usr/share/licenses/${pkgname}/LICENSE
}