aboutsummarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTrent Palmer2018-01-02 02:18:11 -0800
committerTrent Palmer2018-01-02 02:18:11 -0800
commitd2ba6cf9207564729e9e6bc33291bfe369e950b6 (patch)
tree0d43f72ebfa04b2bd102b30fac1c5b6c6ce8ac17
downloadaur-d2ba6cf9207564729e9e6bc33291bfe369e950b6.tar.gz
initial commit with PKGBUILD, README.md, deoplete.install, and .SRCINFO
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD35
-rw-r--r--README.md3
-rw-r--r--deoplete.install31
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3357729b1e21
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = deoplete-git
+ pkgdesc = deoplete completion plugin for neovim
+ pkgver = 3.0.r91.g5c84f5b
+ pkgrel = 1
+ url = https://github.com/Shougo/deoplete.nvim
+ install = deoplete.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = python-neovim
+ depends = python2-neovim
+ provides = deoplete
+ conflicts = deoplete
+ source = deoplete::git://github.com/Shougo/deoplete.nvim
+ md5sums = SKIP
+
+pkgname = deoplete-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..1192cde1a465
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Trent Palmer trenttdually at gmail
+_name='deoplete'
+pkgname="${_name}-git"
+pkgver=3.0.r91.g5c84f5b
+pkgrel=1
+pkgdesc="deoplete completion plugin for neovim"
+arch=('any')
+url="https://github.com/Shougo/deoplete.nvim"
+license=('MIT')
+groups=()
+depends=('python-neovim' 'python2-neovim')
+makedepends=('git')
+provides=('deoplete')
+conflicts=('deoplete')
+replaces=('')
+backup=()
+options=()
+install="${_name}.install"
+source=("${_name}::${url//https/git}")
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_name}"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/share/nvim/runtime"
+ cp -r "${srcdir}/${_name}/"{autoload,doc,plugin,rplugin} \
+ "$pkgdir/usr/share/nvim/runtime"
+
+ install -D -m644 "${srcdir}/${_name}/README.md" $pkgdir/usr/share/doc/$pkgname/README.md
+ install -D -m644 "${srcdir}/${_name}/LICENSE" $pkgdir/usr/share/licenses/$pkgname/LICENSE
+}
diff --git a/README.md b/README.md
new file mode 100644
index 000000000000..358ed313f32e
--- /dev/null
+++ b/README.md
@@ -0,0 +1,3 @@
+### not working
+for now this only works with neovim
+deoplete works with vim, but not yet with this particular package
diff --git a/deoplete.install b/deoplete.install
new file mode 100644
index 000000000000..f83a1d7f4a7a
--- /dev/null
+++ b/deoplete.install
@@ -0,0 +1,31 @@
+update_helptag() {
+ echo -n "Updating neovim (nvim) help tags..."
+ /usr/bin/nvim --noplugins -u NONE -U NONE --cmd ":helptags /usr/share/nvim/runtime/doc" --cmd ":q" > /dev/null 2>&1
+ echo "done. "
+}
+
+post_install() {
+ update_helptag
+ echo ""
+ echo " Note: Python3 must be enabled before updating remote plugins
+ If Deoplete was installed prior to Python support being added to Neovim, :UpdateRemotePlugins
+ should be executed manually in order to enable auto-completion."
+
+ echo ""
+ echo " you might need to add the following to your init.vim/vimrc:
+ \"let g:deoplete#enable_at_startup = 1\""
+ echo ""
+}
+
+post_upgrade() {
+ update_helptag ${1}
+}
+
+post_remove() {
+ update_helptag
+
+ echo ""
+ echo " you might need to remove the following to your init.vim/vimrc:
+ \"let g:deoplete#enable_at_startup = 1\""
+ echo ""
+}