summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlif Rachmawadi2018-01-25 16:57:25 +0700
committerAlif Rachmawadi2018-01-25 16:57:25 +0700
commit0f9d40d304a5f502bf74490f083b4b720068ef87 (patch)
treec5999ff87e3fa147f962c85a141938c1467a1585
downloadaur-0f9d40d304a5f502bf74490f083b4b720068ef87.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--LICENSE27
-rw-r--r--PKGBUILD27
4 files changed, 77 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..127a5a78536d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = dep-bin
+ pkgdesc = Go dependency management tool
+ pkgver = 0.4.1
+ pkgrel = 1
+ url = https://github.com/golang/dep
+ arch = x86_64
+ arch = i686
+ license = BSD
+ provides = dep
+ conflicts = dep
+ source = LICENSE
+ sha256sums = 69c47f09a7aec01c59ff1bdc346406d36e84df11461fb2bed92b0d185a7a2ccb
+ source_x86_64 = https://github.com/golang/dep/releases/download/v0.4.1/dep-linux-amd64
+ sha256sums_x86_64 = 31144e465e52ffbc0035248a10ddea61a09bf28b00784fd3fdd9882c8cbb2315
+ source_i686 = https://github.com/golang/dep/releases/download/v0.4.1/dep-linux-386
+ sha256sums_i686 = 7eecbc4f08f78215a1dbe87af761db1b546ebfea1b60c26e87105e6f63dd6335
+
+pkgname = dep-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..f8cdeaa23f82
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+dep-linux-*
+dep-bin-*.tar.xz
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..a2dd15faf469
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,27 @@
+Copyright (c) 2014 The Go Authors. All rights reserved.
+
+Redistribution and use in source and binary forms, with or without
+modification, are permitted provided that the following conditions are
+met:
+
+ * Redistributions of source code must retain the above copyright
+notice, this list of conditions and the following disclaimer.
+ * Redistributions in binary form must reproduce the above
+copyright notice, this list of conditions and the following disclaimer
+in the documentation and/or other materials provided with the
+distribution.
+ * Neither the name of Google Inc. nor the names of its
+contributors may be used to endorse or promote products derived from
+this software without specific prior written permission.
+
+THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
+"AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
+LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
+A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
+OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
+SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
+LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
+DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
+THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
+(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
+OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..826d7ac7d8db
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Alif Rachmawadi <arch@subosito.com>
+
+pkgname=dep-bin
+pkgver=0.4.1
+pkgrel=1
+pkgdesc="Go dependency management tool"
+arch=('x86_64' 'i686')
+url="https://github.com/golang/dep"
+license=('BSD')
+conflicts=('dep')
+provides=('dep')
+source=("LICENSE")
+source_i686=("${url}/releases/download/v${pkgver}/dep-linux-386")
+source_x86_64=("${url}/releases/download/v${pkgver}/dep-linux-amd64")
+sha256sums=("69c47f09a7aec01c59ff1bdc346406d36e84df11461fb2bed92b0d185a7a2ccb")
+sha256sums_i686=("7eecbc4f08f78215a1dbe87af761db1b546ebfea1b60c26e87105e6f63dd6335")
+sha256sums_x86_64=("31144e465e52ffbc0035248a10ddea61a09bf28b00784fd3fdd9882c8cbb2315")
+
+package() {
+ if [ "${CARCH}" == "x86_64" ]; then
+ install -Dm755 "${srcdir}/dep-linux-amd64" "${pkgdir}/usr/bin/dep"
+ else
+ install -Dm755 "${srcdir}/dep-linux-386" "${pkgdir}/usr/bin/dep"
+ fi
+
+ install -Dm644 "${srcdir}/LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}