summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-03-01 23:43:06 +0100
committerRicardo (XenGi) Band2020-03-01 23:43:06 +0100
commit4a97763593b3ccc4ec9bda0fe9771d8d06753896 (patch)
tree329cf65bba615675fbeb3fad32b40e7a2e307569
parentbc469b456c5a6db7547e8b1dfe0d745a62adacfd (diff)
downloadaur-4a97763593b3ccc4ec9bda0fe9771d8d06753896.tar.gz
fixed dependencies
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 7 insertions, 9 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9504f196c79..4d7ce233bca0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,16 @@
pkgbase = desec-dns-cli
pkgdesc = CLI tool for the desec.io DNS service
pkgver = 0.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://gitlab.com/XenGi/desec-dns-cli
arch = any
license = MIT
checkdepends = python-pytest
- checkdepends = python-pytest-flake8
checkdepends = python-pytest-xdist
- checkdepends = python-responses
+ checkdepends = python-pytest-flake8
makedepends = python-setuptools
depends = python>=3.6
depends = python-click
- depends = python-requests
source = https://files.pythonhosted.org/packages/source/d/desec-dns-cli/desec-dns-cli-0.0.1.tar.gz
sha256sums = ed6ecd486f13a707ce19baffd964392ba1a086052c682cc518cb34dd4a5c5ebb
diff --git a/PKGBUILD b/PKGBUILD
index 10ffd2cd34a2..152ea9d92535 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,20 @@
# Maintainer: Ricardo Band <email@ricardo.band>
pkgname=desec-dns-cli
pkgver=0.0.1
-pkgrel=1
+pkgrel=2
pkgdesc="CLI tool for the desec.io DNS service"
arch=("any")
url=https://gitlab.com/XenGi/desec-dns-cli
license=("MIT")
-depends=("python>=3.6" "python-click" "python-requests")
+depends=("python>=3.6" "python-click")
makedepends=("python-setuptools")
-checkdepends=("python-pytest" "python-pytest-xdist" "python-responses")
+checkdepends=("python-pytest" "python-pytest-xdist" "python-pytest-flake8")
source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
-sha256sums=("ed6ecd486f13a707ce19baffd964392ba1a086052c682cc518cb34dd4a5c5ebb")
+sha256sums=('ed6ecd486f13a707ce19baffd964392ba1a086052c682cc518cb34dd4a5c5ebb')
check() {
cd "$srcdir/$pkgname-$pkgver"
- #pytest tests/
+ pytest --flake8 tests/
}
build() {