summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRicardo (XenGi) Band2020-02-04 23:59:43 +0100
committerRicardo (XenGi) Band2020-02-04 23:59:43 +0100
commitbc469b456c5a6db7547e8b1dfe0d745a62adacfd (patch)
tree9c538be916bc10f36af92162beb82127c35114bf
downloadaur-bc469b456c5a6db7547e8b1dfe0d745a62adacfd.tar.gz
dump first try
-rw-r--r--.SRCINFO20
-rw-r--r--.gitignore20
-rw-r--r--PKGBUILD29
3 files changed, 69 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b9504f196c79
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = desec-dns-cli
+ pkgdesc = CLI tool for the desec.io DNS service
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://gitlab.com/XenGi/desec-dns-cli
+ arch = any
+ license = MIT
+ checkdepends = python-pytest
+ checkdepends = python-pytest-flake8
+ checkdepends = python-pytest-xdist
+ checkdepends = python-responses
+ makedepends = python-setuptools
+ depends = python>=3.6
+ depends = python-click
+ depends = python-requests
+ source = https://files.pythonhosted.org/packages/source/d/desec-dns-cli/desec-dns-cli-0.0.1.tar.gz
+ sha256sums = ed6ecd486f13a707ce19baffd964392ba1a086052c682cc518cb34dd4a5c5ebb
+
+pkgname = desec-dns-cli
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..ccdadf693590
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,20 @@
+
+# Created by https://www.gitignore.io/api/archlinuxpackages
+# Edit at https://www.gitignore.io/?templates=archlinuxpackages
+
+### ArchLinuxPackages ###
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+
+# End of https://www.gitignore.io/api/archlinuxpackages
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..10ffd2cd34a2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: Ricardo Band <email@ricardo.band>
+pkgname=desec-dns-cli
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="CLI tool for the desec.io DNS service"
+arch=("any")
+url=https://gitlab.com/XenGi/desec-dns-cli
+license=("MIT")
+depends=("python>=3.6" "python-click" "python-requests")
+makedepends=("python-setuptools")
+checkdepends=("python-pytest" "python-pytest-xdist" "python-responses")
+source=("https://files.pythonhosted.org/packages/source/${pkgname::1}/$pkgname/$pkgname-$pkgver.tar.gz")
+sha256sums=("ed6ecd486f13a707ce19baffd964392ba1a086052c682cc518cb34dd4a5c5ebb")
+
+check() {
+ cd "$srcdir/$pkgname-$pkgver"
+ #pytest tests/
+}
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py build
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ python setup.py install --root="$pkgdir/" --optimize=1 --skip-build
+}
+