summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin MacMartin2015-06-10 00:37:47 -0400
committerKevin MacMartin2015-06-10 00:37:47 -0400
commit3dea6c981c6b8d62a4d3c8bed18842f2f10029a2 (patch)
treeba64c2e6dbf7ebd7f0ee3dd2a44d8b9de0a75994
downloadaur-3dea6c981c6b8d62a4d3c8bed18842f2f10029a2.tar.gz
Initial import into AUR 4
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD62
-rw-r--r--deskcon-desktop.install3
-rw-r--r--deskcon.163
4 files changed, 152 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..522699a29f4a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = deskcon-desktop-git
+ pkgdesc = Integrates your Smartphone in your Desktop
+ pkgver = 20150501.r93.ca6fcf4
+ pkgrel = 1
+ url = https://github.com/MK-42/deskcon-desktop
+ install = deskcon-desktop.install
+ arch = any
+ license = GPL3
+ makedepends = git
+ depends = python2-pyopenssl
+ depends = python2-gobject
+ depends = python2-dbus
+ depends = pygtk
+ depends = libnotify
+ depends = dbus-glib
+ optdepends = gnome-shell: for use of the included Gnome 3 desktop extension
+ options = !strip
+ source = git+https://github.com/MK-42/deskcon-desktop
+ source = deskcon.1
+ sha512sums = SKIP
+ sha512sums = 144e9a15a01fc63694fa5d26c819ca2474a6cdad802ec1ab984a049b474c4db2419b25ad52f03eb4c2e702524bb0ef6c746fd0436014d8291a83e1e2f4836d2f
+
+pkgname = deskcon-desktop-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d393402e4537
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,62 @@
+# Maintainer: Kevin MacMartin <prurigro@gmail.com>
+
+_pkgname=deskcon-desktop
+pkgname=$_pkgname-git
+pkgver=20150501.r93.ca6fcf4
+pkgrel=1
+pkgdesc='Integrates your Smartphone in your Desktop'
+url='https://github.com/MK-42/deskcon-desktop'
+license=('GPL3')
+arch=('any')
+depends=('python2-pyopenssl' 'python2-gobject' 'python2-dbus' 'pygtk' 'libnotify' 'dbus-glib')
+optdepends=('gnome-shell: for use of the included Gnome 3 desktop extension')
+makedepends=('git')
+options=('!strip')
+install=$_pkgname.install
+source=("git+$url"
+ 'deskcon.1')
+sha512sums=('SKIP'
+ '144e9a15a01fc63694fa5d26c819ca2474a6cdad802ec1ab984a049b474c4db2419b25ad52f03eb4c2e702524bb0ef6c746fd0436014d8291a83e1e2f4836d2f')
+
+pkgver() {
+ cd $_pkgname
+ printf "%s.r%s.%s" "$(git show -s --format=%ci master | sed 's/\ .*//g;s/-//g')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd $_pkgname
+ sed -i 's|"3.14"$|"3.14", "3.16"|' gnome-shell/deskcon@screenfreeze.net/metadata.json
+}
+
+package() {
+ # FOLDER TO INSTALL THE PYTHON FILES
+ _installdir='/usr/share/deskcon-server'
+
+ # INSTALL THE MANPAGE
+ install -Dm644 deskcon.1 "$pkgdir/usr/share/man/man1/deskcon.1"
+
+ # INSTALLY THE PYTHON FILES
+ cd $_pkgname
+ install -d "$pkgdir/usr/"{bin,share/gnome-shell/extensions}
+ cp -r --no-preserve=ownership gnome-shell/deskcon@screenfreeze.net "$pkgdir/usr/share/gnome-shell/extensions/"
+ cd server
+ for file in *; do
+ [[ -f "$file" ]] \
+ && install -D "$file" "$pkgdir$_installdir/$file"
+ done
+ cp -r --no-preserve=ownership share "$pkgdir$_installdir/"
+
+ # CREATE THE LAUNCH SCRIPTS
+ printf '%s\n\n%s\n%s\n' \
+ '#!/usr/bin/env bash' "cd $_installdir" 'python2 settingswindow.py "$@"' \
+ > "$pkgdir/usr/bin/deskcon-server-settings"
+ printf '%s\n\n%s\n%s\n' \
+ '#!/usr/bin/env bash' "cd $_installdir" 'python2 setupdevice.py' \
+ > "$pkgdir/usr/bin/deskcon-setupdevice"
+ printf '%s\n\n%s\n%s\n' \
+ '#!/usr/bin/env bash' "cd $_installdir" 'python2 deskcon-server &' \
+ > "$pkgdir/usr/bin/deskcon-server"
+
+ # MAKE THE LAUNCH SCRIPTS EXECUTABLE
+ chmod 755 "$pkgdir/usr/bin/deskcon-"{server,server-settings,setupdevice}
+}
diff --git a/deskcon-desktop.install b/deskcon-desktop.install
new file mode 100644
index 000000000000..9e0d8911fab4
--- /dev/null
+++ b/deskcon-desktop.install
@@ -0,0 +1,3 @@
+post_install() {
+ printf '%s\n' 'Make sure ports 8082 and 8083 tcp are open before running, and check out the deskcon man page for more information'
+}
diff --git a/deskcon.1 b/deskcon.1
new file mode 100644
index 000000000000..b6aa4fb9ee55
--- /dev/null
+++ b/deskcon.1
@@ -0,0 +1,63 @@
+.if !\n(.g \{\
+. if !\w|\*(lq| \{\
+. ds lq ``
+. if \w'\(lq' .ds lq "\(lq
+. \}
+. if !\w|\*(rq| \{\
+. ds rq ''
+. if \w'\(rq' .ds rq "\(rq
+. \}
+.\}
+.ie t .ds Tx \s-1T\v'.4n'\h'-.1667'E\v'-.4n'\h'-.125'X\s0
+. el .ds Tx TeX
+.de Id
+. ds Yr \\$4
+. substring Yr 0 3
+. ds Mn \\$4
+. substring Mn 5 6
+. ds Dy \\$4
+. substring Dy 8 9
+. \" ISO 8601 date, complete format, extended representation
+. ds Dt \\*(Yr-\\*(Mn-\\*(Dy
+..
+.TH DESKCON 1 \*(Dt "deskcon (git)" "User Commands"
+.hy 0
+.
+.SH "NAME"
+.B DeskCon \-
+Integrates your Smartphone in your Desktop
+.
+.SH "DeskCon"
+Version 0\.3 (GIT)
+.
+.P
+Integrates your Android Device in the Desktop\. Receive Notifications, Files and Commands from your mobile Device on your Desktop PC\. The Data is send over a secure TLS Connection\. The Connection is encrypted and authenticated with self\-signed Certificates (RSA\-2048 PK)\.
+.
+.P
+Warning: This Project is still in development (beta) and may contain some Bugs or Security Holes\. If you find any, please report them ^^
+.
+.SH "Information"
+.
+.nf
+
+\- Project Website http://www\.screenfreeze\.net/deskcon
+\- Source https://github\.com/screenfreeze/deskcon\-desktop
+\- Google Play Store https://play\.google\.com/store/apps/details?id=net\.screenfreeze\.deskcon
+.
+.fi
+.
+.SH "Usage"
+.
+.nf
+
+\- make sure Ports 8082 and 8083 tcp are open
+\- (optional) activate the Gnome3 extension
+\- start the DeskCon Desktop Server by running: deskcon\-server
+\- configure the server by running: deskcon\-server\-settings
+\- (optional) change config File in ~/\.deskcon
+\- To pair with a new Device, start deskcon\-setupdevice or use the Gnome Extension or Unity Indicator
+\- start DeskCon App on your Android Device
+\- select Network > Desktop Hosts
+\- click the + Button and enter the IP of your Desktop PC
+\- check whether the Fingerprints match
+.