summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredrick Brennan2020-10-18 16:06:56 -0700
committerFredrick Brennan2020-10-18 16:06:56 -0700
commit63033d1d78d4f6a17b30ab17a801a07ec4ee06f4 (patch)
tree180f34a9b74ee0c456bf83d29ca10ce08302a60e
downloadaur-63033d1d78d4f6a17b30ab17a801a07ec4ee06f4.tar.gz
Initial commit
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD31
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5abdaabbfa51
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = deskew-git
+ pkgdesc = deskew is a command-line program which deskews images containing text
+ pkgver = v1.30.r15.gb8f5ff6
+ pkgrel = 1
+ url = http://jwilk.net/software/deskew
+ arch = any
+ license = MIT
+ makedepends = fpc
+ provides = deskew
+ source = deskew::git+https://github.com/galfar/deskew
+ md5sums = SKIP
+
+pkgname = deskew-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aa01aaab8eb9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Fredrick Brennan <copypaste@kittens.ph>
+
+pkgname=deskew-git
+_name=deskew
+_user=galfar
+pkgrel=1
+pkgver=v1.30.r15.gb8f5ff6
+pkgdesc="deskew is a command-line program which deskews images containing text"
+arch=("any")
+url="http://jwilk.net/software/deskew"
+license=('MIT')
+makedepends=('fpc')
+source=("${_name}::git+https://github.com/${_user}/${_name}")
+provides=('deskew')
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_name"
+ git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+package() {
+ cd "$_name"
+ cd Scripts
+ # Change \r\n to \n
+ tr -d '\r' < Compile.bat > compile.sh
+ chmod +x compile.sh
+ # This file just makes a dir. & calls `fpc` as of when I wrote this PKGBUILD
+ ./compile.sh
+ install -D "$srcdir/${_name}/Bin/deskew" "$pkgdir/usr/bin/deskew"
+}