summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFredrick Brennan2018-08-07 21:48:33 +0800
committerFredrick Brennan2018-08-07 21:48:33 +0800
commit58ad04ab56b7500a59b2309842ab365ac1b67aa8 (patch)
tree965d60c02f8bd5511eba54b0e40ccba0a1e8d7fc
downloadaur-58ad04ab56b7500a59b2309842ab365ac1b67aa8.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a681d4fbd4c7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = deskew-hg
+ pkgdesc = deskew is a command-line program which deskews images containing text
+ pkgver = 30.2c46db9991ab
+ pkgrel = 1
+ url = http://galfar.vevb.net/wp/projects/deskew/
+ arch = any
+ license = MIT
+ makedepends = mercurial
+ makedepends = fpc
+ provides = deskew
+ source = app-deskew::hg+https://bitbucket.org/galfar/app-deskew
+ md5sums = SKIP
+
+pkgname = deskew-hg
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b86559176558
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Fredrick Brennan <copypaste@kittens.ph>
+
+pkgname=deskew-hg
+_hgname=app-deskew
+_bbuser=galfar
+pkgrel=1
+pkgver=30.2c46db9991ab
+pkgdesc="deskew is a command-line program which deskews images containing text"
+arch=("any")
+url="http://jwilk.net/software/deskew"
+license=('MIT')
+depends=('python')
+makedepends=('mercurial' 'fpc')
+source=("${_hgname}::hg+https://bitbucket.org/${_bbuser}/${_hgname}")
+provides=('deskew')
+md5sums=("SKIP")
+
+pkgver() {
+ cd "$_hgname"
+ echo "$(hg identify -n).$(hg identify -i)"
+}
+
+package() {
+ cd "$_hgname"
+ # Change \r\n to \n
+ tr -d '\r' < Compile.bat > compile.sh
+ chmod +x compile.sh
+ # This file just makes a dir. & calls `fpc` as of when I wrote this PKGBUILD
+ ./compile.sh
+ install -Dm644 "$srcdir/${_hgname}/Bin/deskew" "$pkgdir/usr/bin/deskew"
+}