summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12019-05-23 01:25:48 +0800
committerChocobo12019-05-23 01:25:48 +0800
commit30e4bd808c9528a2a4778a92fcb2aca82a6ecda6 (patch)
tree01bf9f69e98335394aa74db50f309468085710bb
parent8453239c4aaaeef4d922563ce8b9b413cc3922dd (diff)
downloadaur-30e4bd808c9528a2a4778a92fcb2aca82a6ecda6.tar.gz
upgpkg: desktop-file-utils-git 0.23.r4.g92af410-1
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD11
2 files changed, 8 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 7eba586d2026..d572d329a933 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = desktop-file-utils-git
pkgdesc = Command line utilities for working with desktop entries
- pkgver = 0.23.r3.g5b88c95
+ pkgver = 0.23.r4.g92af410
pkgrel = 1
url = https://www.freedesktop.org/wiki/Software/desktop-file-utils/
arch = i686
@@ -11,7 +11,7 @@ pkgbase = desktop-file-utils-git
depends = glib2
provides = desktop-file-utils
conflicts = desktop-file-utils
- source = git+https://anongit.freedesktop.org/git/xdg/desktop-file-utils.git
+ source = git+https://gitlab.freedesktop.org/xdg/desktop-file-utils.git
source = update-desktop-database.hook::https://git.archlinux.org/svntogit/packages.git/plain/trunk/update-desktop-database.hook?h=packages/desktop-file-utils
sha256sums = SKIP
sha256sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index c8ecdb548d00..9e33de8cfc12 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=desktop-file-utils-git
-pkgver=0.23.r3.g5b88c95
+pkgver=0.23.r4.g92af410
pkgrel=1
pkgdesc="Command line utilities for working with desktop entries"
arch=('i686' 'x86_64')
@@ -11,7 +11,7 @@ depends=('glibc' 'glib2')
makedepends=('git')
provides=('desktop-file-utils')
conflicts=('desktop-file-utils')
-source=("git+https://anongit.freedesktop.org/git/xdg/desktop-file-utils.git"
+source=("git+https://gitlab.freedesktop.org/xdg/desktop-file-utils.git"
"update-desktop-database.hook::https://git.archlinux.org/svntogit/packages.git/plain/trunk/update-desktop-database.hook?h=packages/desktop-file-utils")
sha256sums=('SKIP'
'SKIP')
@@ -26,8 +26,9 @@ pkgver() {
build() {
cd "desktop-file-utils"
- ./autogen.sh
- ./configure --prefix="/usr"
+ NOCONFIGURE=1 ./autogen.sh
+ ./configure \
+ --prefix="/usr"
make
}
@@ -36,5 +37,5 @@ package() {
make DESTDIR="$pkgdir" install
- install -Dm644 "$srcdir/update-desktop-database.hook" "$pkgdir/usr/share/libalpm/hooks/update-desktop-database.hook"
+ install -Dm644 "$srcdir/update-desktop-database.hook" -t "$pkgdir/usr/share/libalpm/hooks"
}