summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-25 16:24:59 +0800
committerzxp198210052024-01-25 16:24:59 +0800
commita54bf1aeb465ce1354b09f782825bac2b0ead222 (patch)
tree3cccf606d0baba225277dee657df69caaeb3b45e
parenteea0fd1dfa43d56eea145618214408c142901520 (diff)
downloadaur-a54bf1aeb465ce1354b09f782825bac2b0ead222.tar.gz
fix errors
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD11
2 files changed, 7 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bbfc32183d68..3b0f6679e2db 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,21 @@
pkgbase = desktop-notifier-bin
pkgdesc = Application which sent a notifier when data change about a link
pkgver = 0.0.8
- pkgrel = 7
+ pkgrel = 8
url = https://github.com/maxgfr/desktop-notifier
arch = x86_64
license = custom
makedepends = squashfuse
depends = electron23
depends = hicolor-icon-theme
- depends = libx11
- depends = gdk-pixbuf2
- depends = libxext
+ depends = dbus-glib
depends = libdbusmenu-glib
depends = gtk2
- depends = dbus-glib
provides = desktop-notifier=0.0.8
conflicts = desktop-notifier
source = desktop-notifier-0.0.8.AppImage::https://github.com/maxgfr/desktop-notifier/releases/download/0.0.8/Desktop.Notifier-0.0.7.AppImage
source = desktop-notifier.sh
sha256sums = bcde59d6d7501d990adfe88f08c9794153df98177da073b80442fab2c8d13abe
- sha256sums = 5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf
+ sha256sums = 1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8
pkgname = desktop-notifier-bin
diff --git a/PKGBUILD b/PKGBUILD
index 49d9cd77daa6..e604aca8571c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@ pkgname=desktop-notifier-bin
_appname=Desktop.Notifier
pkgver=0.0.8
_electronversion=23
-pkgrel=7
+pkgrel=8
pkgdesc="Application which sent a notifier when data change about a link"
arch=('x86_64')
url="https://github.com/maxgfr/desktop-notifier"
@@ -13,12 +13,9 @@ conflicts=("${pkgname%-bin}")
depends=(
"electron${_electronversion}"
'hicolor-icon-theme'
- 'libx11'
- 'gdk-pixbuf2'
- 'libxext'
+ 'dbus-glib'
'libdbusmenu-glib'
'gtk2'
- 'dbus-glib'
)
makedepends=(
'squashfuse'
@@ -28,7 +25,7 @@ source=(
"${pkgname%-bin}.sh"
)
sha256sums=('bcde59d6d7501d990adfe88f08c9794153df98177da073b80442fab2c8d13abe'
- '5ce46265f0335b03568aa06f7b4c57c5f8ffade7a226489ea39796be91a511bf')
+ '1d3f21d54a2d9d1a53661bd91c2afd00df79b0ce4057a66b4c953febfc464cd8')
build() {
sed -e "s|@electronversion@|${_electronversion}|g" \
-e "s|@appname@|${pkgname%-bin}|g" \
@@ -36,7 +33,7 @@ build() {
-i "${srcdir}/${pkgname%-bin}.sh"
chmod a+x "${srcdir}/${pkgname%-bin}-${pkgver}.AppImage"
"${srcdir}/${pkgname%-bin}-${pkgver}.AppImage" --appimage-extract > /dev/null
- sed "s|AppRun --no-sandbox %U|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
+ sed "s|AppRun --no-sandbox|${pkgname%-bin}|g" -i "${srcdir}/squashfs-root/${pkgname%-bin}.desktop"
find "${srcdir}/squashfs-root/resources" -type d -exec chmod 755 {} \;
}
package() {