summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormax.bra2023-08-27 10:47:03 +0200
committermax.bra2023-08-27 10:47:03 +0200
commitd2ef9dc17cdad7fff5b4d51d40ff951342915094 (patch)
treef5aaee4f9050bb445709b7be5baf7693958e32ae
parent94e8d6cc95ed3143c06fa8aaaf5d24ac8e2199a9 (diff)
downloadaur-d2ef9dc17cdad7fff5b4d51d40ff951342915094.tar.gz
mason build error
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD15
2 files changed, 14 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6c0f75728272..48a30f08fb5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,8 +12,10 @@ pkgbase = desktopfolder
makedepends = intltool
depends = libwnck3
depends = gtksourceview3
+ depends = libgee
source = https://github.com/spheras/desktopfolder/archive/v1.1.3.zip
+ source = mason.patch::https://github.com/spheras/desktopfolder/commit/a340264fce3d0a0576db559e159415c4713de753.patch
sha256sums = 6d03839c8e890d11817e253b48d59c6d31bf09a0a0e6f698e7b98f7fe810ce8c
+ sha256sums = fc6058f0a935079552c5508e75786556f812c5855a2f4b792d4881c68c13e48a
pkgname = desktopfolder
-
diff --git a/PKGBUILD b/PKGBUILD
index 01b82ba36ade..28ff4ba04304 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,17 +7,24 @@ pkgdesc='Organize your desktop with panels that hold your things.'
arch=('i686' 'x86_64')
url='https://github.com/spheras/desktopfolder'
license=('GPL3')
-depends=('libwnck3' 'gtksourceview3')
+depends=('libwnck3' 'gtksourceview3' 'libgee')
makedepends=('meson' 'ninja' 'vala' 'intltool')
-source=("https://github.com/spheras/${pkgname}/archive/v${pkgver}.zip")
+source=("https://github.com/spheras/${pkgname}/archive/v${pkgver}.zip"
+ mason.patch::"https://github.com/spheras/${pkgname}/commit/a340264fce3d0a0576db559e159415c4713de753.patch")
-sha256sums=('6d03839c8e890d11817e253b48d59c6d31bf09a0a0e6f698e7b98f7fe810ce8c')
+sha256sums=('6d03839c8e890d11817e253b48d59c6d31bf09a0a0e6f698e7b98f7fe810ce8c'
+ 'fc6058f0a935079552c5508e75786556f812c5855a2f4b792d4881c68c13e48a')
+
+prepare() {
+ cd "$srcdir"/"$pkgname"-"$pkgver"
+ patch -Np1 -i "$srcdir"/mason.patch
+}
build() {
cd ${pkgname}-${pkgver}
meson build --prefix=/usr
cd build
- meson configure
+ meson configure -D prefix=/usr
ninja
}