summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorbegin-theadventure2023-09-23 12:48:14 +0200
committerbegin-theadventure2023-09-23 12:48:14 +0200
commit842add08754647f5274d0a90d05f85ccf1d63fed (patch)
treedf84dc5f82d87bad7962b45e84be87a4759bc4da
downloadaur-842add08754647f5274d0a90d05f85ccf1d63fed.tar.gz
1.0.7
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD23
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8e6cf47290e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = desktopius
+ pkgdesc = The application allows you to create and edit desktop files
+ pkgver = 1.0.7
+ pkgrel = 1
+ url = https://github.com/alexkdeveloper/dfc
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = vala
+ depends = granite
+ source = desktopius::git+https://github.com/alexkdeveloper/dfc.git#tag=1.0.7
+ sha256sums = SKIP
+
+pkgname = desktopius
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c0bc85a609ea
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,23 @@
+# Maintainer: begin-theadventure <begin-thecontact.ncncb at dralias dot com>
+
+pkgname=desktopius
+pkgdesc='The application allows you to create and edit desktop files'
+pkgver=1.0.7
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/alexkdeveloper/dfc"
+license=('GPL3')
+depends=('granite')
+makedepends=('git' 'meson' 'vala')
+source=("desktopius::git+$url.git#tag=$pkgver")
+sha256sums=('SKIP')
+
+build() {
+ arch-meson $pkgname build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" meson install -C build
+ ln -s /usr/bin/com.github.alexkdeveloper.dfc "$pkgdir/usr/bin/$pkgname"
+}