summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122015-06-08 11:41:12 +0200
committerwillemw122015-06-08 11:41:12 +0200
commitf03ad1750a47f91a606346afe9b6be452efa52b1 (patch)
tree7a6a3da79180d9fc478c2e6e65b70ab9a41b130f
downloadaur-f03ad1750a47f91a606346afe9b6be452efa52b1.tar.gz
Initial commit
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD27
-rw-r--r--desktopnova.install12
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..de8946368080
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+pkgbase = desktopnova
+ pkgdesc = Changes your desktop wallpaper automatically after a preset period of time
+ pkgver = 0.8.1
+ pkgrel = 4
+ url = https://launchpad.net/desktopnova
+ install = desktopnova.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ makedepends = intltool
+ depends = gconf
+ depends = gtk2
+ depends = gtk-update-icon-cache
+ depends = libxml2
+ depends = xfconf
+ source = https://launchpad.net/desktopnova/0.8/0.8.1/+download/desktopnova-0.8.1.tar.gz
+ md5sums = f1ce5cc731ddcb999ac09ff8461228b9
+
+pkgname = desktopnova
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..0778f7fc6709
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: willemw <willemw12@gmail.com>
+# Contributor: Alessandro Nakamuta <alessandro dot ufms at gmail dot com>
+
+pkgname=desktopnova
+pkgver=0.8.1
+pkgrel=4
+pkgdesc="Changes your desktop wallpaper automatically after a preset period of time"
+arch=('i686' 'x86_64')
+url="https://launchpad.net/desktopnova"
+license=('GPL')
+depends=('gconf' 'gtk2' 'gtk-update-icon-cache' 'libxml2' 'xfconf')
+makedepends=('cmake' 'intltool')
+install=$pkgname.install
+source=(https://launchpad.net/desktopnova/0.8/$pkgver/+download/$pkgname-$pkgver.tar.gz)
+md5sums=('f1ce5cc731ddcb999ac09ff8461228b9')
+
+build(){
+ cd $pkgname-$pkgver
+ cmake -DCMAKE_INSTALL_PREFIX=/usr .
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir" install
+}
+
diff --git a/desktopnova.install b/desktopnova.install
new file mode 100644
index 000000000000..d641c9a2c2de
--- /dev/null
+++ b/desktopnova.install
@@ -0,0 +1,12 @@
+post_install() {
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install $1
+}
+
+post_remove() {
+ post_install $1
+}
+