summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwillemw122017-06-24 09:27:18 +0200
committerwillemw122017-06-24 09:27:18 +0200
commitff6c71e8f5f957900cfa12a6672b667811a2312f (patch)
treeb8037b739e101a26d345a07815a38d351c8f3adb
parentf03ad1750a47f91a606346afe9b6be452efa52b1 (diff)
downloadaur-ff6c71e8f5f957900cfa12a6672b667811a2312f.tar.gz
Add dbus and python2. Remove .install file. Fix "dbus-server-bindings.h" file generation
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD18
-rw-r--r--desktopnova.install12
3 files changed, 18 insertions, 20 deletions
diff --git a/.SRCINFO b/.SRCINFO
index de8946368080..fb24728ffd31 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Jun 24 07:24:25 UTC 2017
pkgbase = desktopnova
pkgdesc = Changes your desktop wallpaper automatically after a preset period of time
pkgver = 0.8.1
- pkgrel = 4
+ pkgrel = 5
url = https://launchpad.net/desktopnova
- install = desktopnova.install
arch = i686
arch = x86_64
license = GPL
makedepends = cmake
makedepends = intltool
+ makedepends = python2
depends = gconf
- depends = gtk2
depends = gtk-update-icon-cache
+ depends = libdbusmenu-gtk2
depends = libxml2
depends = xfconf
source = https://launchpad.net/desktopnova/0.8/0.8.1/+download/desktopnova-0.8.1.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
index 0778f7fc6709..1f23cc910580 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,20 +3,28 @@
pkgname=desktopnova
pkgver=0.8.1
-pkgrel=4
+pkgrel=5
pkgdesc="Changes your desktop wallpaper automatically after a preset period of time"
arch=('i686' 'x86_64')
url="https://launchpad.net/desktopnova"
license=('GPL')
-depends=('gconf' 'gtk2' 'gtk-update-icon-cache' 'libxml2' 'xfconf')
-makedepends=('cmake' 'intltool')
-install=$pkgname.install
+depends=('gconf' 'gtk-update-icon-cache' 'libdbusmenu-gtk2' 'libxml2' 'xfconf')
+makedepends=('cmake' 'intltool' 'python2')
source=(https://launchpad.net/desktopnova/0.8/$pkgver/+download/$pkgname-$pkgver.tar.gz)
md5sums=('f1ce5cc731ddcb999ac09ff8461228b9')
-build(){
+prepare() {
+ cd $pkgname-$pkgver
+ sed -i 's/\bpython\b/python2/g' generate-translators.py ascii-to-header.py src/misc/CMakeLists.txt
+}
+
+build() {
cd $pkgname-$pkgver
cmake -DCMAKE_INSTALL_PREFIX=/usr .
+
+ # Fix "dbus-server-bindings.h: No such file or directory"
+ make asciis-to-headers desktopnova-general desktopnova-module
+
make
}
diff --git a/desktopnova.install b/desktopnova.install
deleted file mode 100644
index d641c9a2c2de..000000000000
--- a/desktopnova.install
+++ /dev/null
@@ -1,12 +0,0 @@
-post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-}
-
-post_upgrade() {
- post_install $1
-}
-
-post_remove() {
- post_install $1
-}
-