summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarkus Kitsinger (SwooshyCueb)2017-01-11 17:36:02 -0600
committerMarkus Kitsinger (SwooshyCueb)2017-01-11 17:36:02 -0600
commit50c58917749c0a1c16977e4c35b4ec121833b609 (patch)
treebc198d397b6a1ed31d15e1bfc2cabf319e8427bf
parent76139d73b220eee9689e7317c46d25d024439370 (diff)
downloadaur-50c58917749c0a1c16977e4c35b4ec121833b609.tar.gz
Disable hud and wifi so the damn thing actually works
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD22
2 files changed, 7 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8af32e82d794..1f77fda4d0f0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Wed Jan 11 14:51:49 UTC 2017
+# Wed Jan 11 23:35:43 UTC 2017
pkgbase = desmume-git
pkgdesc = Nintendo DS emulator
pkgver = 0.9.11.r583.07a68db
- pkgrel = 1
+ pkgrel = 2
url = http://desmume.org/
arch = i686
arch = x86_64
@@ -13,10 +13,8 @@ pkgbase = desmume-git
makedepends = pkg-config
makedepends = git
makedepends = lua
- depends = agg
depends = gtkglext
depends = libglade
- depends = libpcap
depends = libgl
depends = openal
depends = sdl
diff --git a/PKGBUILD b/PKGBUILD
index 538084e19524..15bf82f7b68e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -14,12 +14,10 @@ license=('GPL')
_last_rtm_ver=0.9.11
_last_rtm_commit=ccbf85ed42e4350af415d56b1465e83614c85ef8
pkgver="${_last_rtm_ver}.r583.07a68db"
-pkgrel=1
+pkgrel=2
-depends=('agg'
- 'gtkglext'
+depends=('gtkglext'
'libglade'
- 'libpcap'
'libgl'
'openal'
'sdl'
@@ -29,7 +27,6 @@ makedepends=('autoconf'
'automake'
'pkg-config'
'git'
- #'clang'
'lua')
provides=('desmume')
@@ -59,32 +56,23 @@ prepare(){
# we could probably just make it compile against the current lua
sed -i 's/lua5.1/lua51/' configure.ac
- # Make clang happy
- #sed -e 's/^\([[:space:]]\+\) \(line_profile_aa& profile\)/\1 const \2/' /usr/include/agg2/agg_renderer_outline_aa.h > ../modules/osd/agg/agg_renderer_outline_aa.h
-
./autogen.sh
- # Using clang to workaround FS#41476
- # Not sure if we need to do this, since it seems the current codebase
- # doesn't quite work anyway.
- #CC=clang \
- #CXX=clang++ \
+ # Hud causes segfault in gtk version. Wifi doesn't really work.
CFLAGS="-O3 -march=native" \
CXXFLAGS="-O3 -march=native" \
./configure \
--prefix=/usr \
--enable-osmesa \
--enable-glx \
- --enable-hud \
--enable-openal \
- --enable-glade \
- --enable-wifi
+ --enable-glade
}
build() {
cd "${srcdir}/${_pkgname}/${_builddir}"
- make -j6
+ make
}
package() {