summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Tobias2020-09-10 14:11:44 +1000
committerDaniel Tobias2020-09-10 14:11:44 +1000
commitb3c907849569ce89452773338719c33715e60ec5 (patch)
treeced473dc6c42b696a3322ddd37c4316813794277
parent6e8e3998accd26512d4450aec1f8ec4a5e689fb9 (diff)
downloadaur-b3c907849569ce89452773338719c33715e60ec5.tar.gz
add FORTIFY_SOURCE and PIE
-rw-r--r--PKGBUILD12
1 files changed, 11 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c9dc9c3343ae..e3c389b9258b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -30,7 +30,17 @@ prepare(){
git submodule update --init --recursive
cd "${srcdir}/${_pkgname}/${_builddir}"
- meson setup ../../../build/ --prefix=/usr --buildtype=release --optimization=2 --strip -Dopenal=true -Dc_args=-minline-all-stringops #-Dwifi=true #wifi wants libagg??
+
+ meson setup ../../../build/ \
+ --prefix=/usr \
+ --buildtype=release \
+ --optimization=2 \
+ --strip \
+ -Dc_args='-minline-all-stringops -D_FORTIFY_SOURCE=2' \
+ -Db_pie=true \
+ -Dopenal=true
+ #-Dwifi=true #wifi wants libagg??
+
meson configure ../../../build/
}