summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDan Johansen2024-08-27 20:11:35 +0200
committerDan Johansen2024-08-27 20:11:35 +0200
commitdcc39fd3bb733fd686a3af3d38f543692b88b308 (patch)
tree83be8e853c532391cab0a6f36eee4271ba676da5
parentab9e7805c227845a9f07bf85ad4025192880575d (diff)
downloadaur-dcc39fd3bb733fd686a3af3d38f543692b88b308.tar.gz
fix dependencies
Signed-off-by: Dan Johansen <strit@strits.dk>
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD38
2 files changed, 34 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d3f9d2ee8939..8d79def9a9ba 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = desq-shell
pkgdesc = The Desktop Shell for Desq
pkgver = 0.0.8
- pkgrel = 4
+ pkgrel = 6
url = https://gitlab.com/DesQ/Shell
arch = x86_64
arch = aarch64
@@ -13,6 +13,7 @@ pkgbase = desq-shell
depends = libdbusmenu-qt5
depends = libxcomposite
depends = libdesqui
+ depends = libcanberra
depends = pam
depends = qt5-svg
depends = wayland-protocols
diff --git a/PKGBUILD b/PKGBUILD
index 7876f2f0ab82..663dd2cd03ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,48 @@
_pkgname=Shell
pkgname=desq-shell
pkgver=0.0.8
-pkgrel=4
+pkgrel=6
pkgdesc="The Desktop Shell for Desq"
arch=('x86_64' 'aarch64')
url="https://gitlab.com/DesQ/${_pkgname}"
license=('GPL3')
-depends=('qt5-base' 'qt5-x11extras' 'libdbusmenu-qt5' 'libxcomposite' 'libdesqui' 'pam' 'qt5-svg' 'wayland-protocols'
- 'dfl-utils' 'dfl-xdg' 'dfl-ipc' 'dfl-applications' 'dfl-settings' 'dfl-layouts' 'dfl-wayqt' 'dfl-status-notifier'
- 'dfl-hjsonparser' 'dfl-colorschemeparser' 'dfl-power' 'dfl-login1' 'dfl-inotify' 'dfl-volume' 'wayfire'
- 'wayfire-plugins-extra' 'wayfire-plugins-wfconfig-hjson' 'wayfire-plugins-dbusqt' 'wayfire-plugins-desq-shell'
+depends=('qt5-base'
+ 'qt5-x11extras'
+ 'libdbusmenu-qt5'
+ 'libxcomposite'
+ 'libdesqui'
+ 'libcanberra'
+ 'pam'
+ 'qt5-svg'
+ 'wayland-protocols'
+ 'dfl-utils'
+ 'dfl-xdg'
+ 'dfl-ipc'
+ 'dfl-applications'
+ 'dfl-settings'
+ 'dfl-layouts'
+ 'dfl-wayqt'
+ 'dfl-status-notifier'
+ 'dfl-hjsonparser'
+ 'dfl-colorschemeparser'
+ 'dfl-power'
+ 'dfl-login1'
+ 'dfl-inotify'
+ 'dfl-volume'
+ 'wayfire'
+ 'wayfire-plugins-extra'
+ 'wayfire-plugins-wfconfig-hjson'
+ 'wayfire-plugins-dbusqt'
+ 'wayfire-plugins-desq-shell'
'wayfire-plugins-toplevel-manager')
-makedepends=('meson' 'ninja')
+makedepends=('meson'
+ 'ninja')
source=("https://gitlab.com/DesQ/${_pkgname}/-/archive/v${pkgver}/${_pkgname}-v${pkgver}.tar.gz")
md5sums=('063db58d9f9f062f4f72f562b4852ca8')
build() {
cd "${_pkgname}-v${pkgver}"
+ PKG_CONFIG_PATH=/usr/lib/wlroots0.17/pkgconfig \
meson setup .build --prefix=/usr --buildtype=release
ninja -C .build
}