summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Bell2020-07-08 17:13:37 -0400
committerStephen Bell2020-07-08 17:13:37 -0400
commitcc338419febce84d2e6bb9067d21d7739d0d7528 (patch)
treefcf63f0ca91962e4d40fe74938903a014d2049eb
parentf4f47dd8d2294e8023521f483ca1863f79a3edb2 (diff)
downloadaur-cc338419febce84d2e6bb9067d21d7739d0d7528.tar.gz
Updated to 2.0.0
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD23
2 files changed, 15 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44644ca4c525..94af81197586 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = destinationsol
pkgdesc = 2D Space Arcade/RPG with Planets
- pkgver = 2.0.0beta
- pkgrel = 2
+ pkgver = 2.0.0
+ pkgrel = 1
url = https://github.com/MovingBlocks/DestinationSol
arch = i686
arch = x86_64
license = Apache V2
- makedepends = unzip
makedepends = icoutils
depends = java-runtime-common
+ source = https://github.com/MovingBlocks/DestinationSol/releases/download/v2.0.0/DestinationSol.zip
+ sha1sums = 4d704a882eed7dec9f520d8ec5893985c91809bd
pkgname = destinationsol
diff --git a/PKGBUILD b/PKGBUILD
index a6a37f676e7b..a39ecb1f0a93 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,26 @@
# Maintainer: Stephen Bell <theredbaron1834 @ yahoo.com>
pkgname=destinationsol
-pkgrel=2
-pkgver=2.0.0beta
+pkgrel=1
+pkgver=2.0.0
pkgdesc="2D Space Arcade/RPG with Planets"
arch=('i686' 'x86_64')
url="https://github.com/MovingBlocks/DestinationSol"
license=('Apache V2')
depends=('java-runtime-common')
-makedepends=('unzip' 'icoutils')
+makedepends=('icoutils')
+source=("$url/releases/download/v$pkgver/DestinationSol.zip")
+sha1sums=('4d704a882eed7dec9f520d8ec5893985c91809bd')
build() {
- mkdir "$srcdir/DestinationSol"
- cd "$srcdir"/DestinationSol
- msg "Grabbing files...."
- curl https://github.com/MovingBlocks/DestinationSol/releases/download/v2.0.0-beta/DestinationSol.zip -L -o DestinationSol.zip
- unzip DestinationSol.zip
- wrestool -x -t 14 "$srcdir/DestinationSol/sol.exe" > "$srcdir/DestinationSol/icon.ico"
+ wrestool -x -t 14 sol.exe > icon.ico
+ rm -rf lwjre lwjreOSX
+ rm -f sol.exe sol*.sh
+ rm DestinationSol.zip
}
package() {
- cd "$pkgdir"
-install -m777 -d "$pkgdir/opt/DestinationSol"
- cp -r "$srcdir/DestinationSol/" "$pkgdir/opt/"
+ install -m777 -d "$pkgdir/opt/DestinationSol"
+ mv * "$pkgdir/opt/DestinationSol/"
mkdir -p "$pkgdir/usr/share/applications/"
mkdir -p "$pkgdir/usr/bin/"