summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorStephen Bell2020-04-28 19:07:41 -0400
committerStephen Bell2020-04-28 19:07:41 -0400
commitf4f47dd8d2294e8023521f483ca1863f79a3edb2 (patch)
tree56afc889e0681f31b41915b682671b13e6c87995
parentb470c6ca964dd78fe2b3bcbb97725df2ef89cf8f (diff)
downloadaur-f4f47dd8d2294e8023521f483ca1863f79a3edb2.tar.gz
Upgrade to 2.0.0 beta
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb5b15e1f353..44644ca4c525 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = destinationsol
pkgdesc = 2D Space Arcade/RPG with Planets
- pkgver = 1.5.0
+ pkgver = 2.0.0beta
pkgrel = 2
url = https://github.com/MovingBlocks/DestinationSol
arch = i686
arch = x86_64
license = Apache V2
makedepends = unzip
+ makedepends = icoutils
depends = java-runtime-common
pkgname = destinationsol
diff --git a/PKGBUILD b/PKGBUILD
index 2c8e30b6f2bb..a6a37f676e7b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,27 +1,28 @@
# Maintainer: Stephen Bell <theredbaron1834 @ yahoo.com>
pkgname=destinationsol
pkgrel=2
-pkgver=1.5.0
+pkgver=2.0.0beta
pkgdesc="2D Space Arcade/RPG with Planets"
arch=('i686' 'x86_64')
url="https://github.com/MovingBlocks/DestinationSol"
license=('Apache V2')
depends=('java-runtime-common')
-makedepends=('unzip')
+makedepends=('unzip' 'icoutils')
build() {
mkdir "$srcdir/DestinationSol"
cd "$srcdir"/DestinationSol
msg "Grabbing files...."
- curl https://github.com/MovingBlocks/DestinationSol/releases/download/v1.5.0/DestinationSol1.5.0.zip -L -o DestinationSol.zip
+ curl https://github.com/MovingBlocks/DestinationSol/releases/download/v2.0.0-beta/DestinationSol.zip -L -o DestinationSol.zip
unzip DestinationSol.zip
+ wrestool -x -t 14 "$srcdir/DestinationSol/sol.exe" > "$srcdir/DestinationSol/icon.ico"
}
package() {
cd "$pkgdir"
install -m777 -d "$pkgdir/opt/DestinationSol"
- cp -r "$srcdir/DestinationSol/libs" "$pkgdir/opt/DestinationSol/"
- cp -r "$srcdir/DestinationSol/res" "$pkgdir/opt/DestinationSol/"
+ cp -r "$srcdir/DestinationSol/" "$pkgdir/opt/"
+
mkdir -p "$pkgdir/usr/share/applications/"
mkdir -p "$pkgdir/usr/bin/"
echo "[Desktop Entry]
@@ -29,7 +30,7 @@ Name=Destination Sol
GenericName=Destination Sol
Comment=2D Space Arcade/RPG with Planets
Exec=DestinationSol
-Icon=/opt/DestinationSol/res/icon.png
+Icon=/opt/DestinationSol/icon.ico
Terminal=false
Type=Application
Categories=Game;" > "$pkgdir/usr/share/applications/DestinationSol.desktop"