summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCritzlez2020-03-18 11:28:54 -0700
committerCritzlez2020-03-18 11:28:54 -0700
commit0db5a9177a313e8aa29d9b9cc97ffe8181a11468 (patch)
treef559688a24b3d1acf41d86dcb270d969e81aef41
parentf7201d0698aa1b359a22b2b8b3759030da95f3ef (diff)
downloadaur-0db5a9177a313e8aa29d9b9cc97ffe8181a11468.tar.gz
add .install for instructions for the config file
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD16
-rw-r--r--detect-tablet-mode-git.install33
3 files changed, 43 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cde7d66ca2b6..a034424b08e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = detect-tablet-mode-git
pkgdesc = Detects both normal & tablet mode, executing custom scripts/commands for each mode. See the github page for instructions.
pkgver = master
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/alesguzik/linux_detect_tablet_mode
+ install = detect-tablet-mode-git.install
arch = any
- license = GPL
+ license = MIT
makedepends = git
depends = ruby
depends = libinput
diff --git a/PKGBUILD b/PKGBUILD
index 8714d3519e5b..2500612d6f01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,25 +3,23 @@ pkgname=detect-tablet-mode-git
pkgver=master
pkgrel=3
pkgdesc="Detects both normal & tablet mode, executing custom scripts/commands for each mode. See the github page for instructions."
-arch=('any')
-url='https://github.com/alesguzik/linux_detect_tablet_mode'
-license=('MIT')
+arch=("any")
+url="https://github.com/alesguzik/linux_detect_tablet_mode"
+license=("MIT")
groups=()
-depends=('ruby' 'libinput')
-makedepends=('git')
+depends=("ruby" "libinput")
+makedepends=("git")
optdepends=()
provides=()
conflicts=()
replaces=()
backup=()
options=()
-install=
+install="$pkgname.install"
changelog=
source=("$pkgname::git+$url")
noextract=()
-sha256sums=('SKIP')
-#build() {
-#}
+sha256sums=("SKIP")
package() {
cd $pkgname
diff --git a/detect-tablet-mode-git.install b/detect-tablet-mode-git.install
new file mode 100644
index 000000000000..b5226473bbee
--- /dev/null
+++ b/detect-tablet-mode-git.install
@@ -0,0 +1,33 @@
+
+## arg 1: the new package version
+#pre_install() {
+ # do something here
+#}
+
+## arg 1: the new package version
+post_install() {
+ echo "====> The config file has been placed into /etc/watch_tablet.yml.example. Copy it to your ~/.config/ folder, rename
+ it to watch_tablet.yml, and modify it to your needs."
+}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#pre_upgrade() {
+ # do something here
+#}
+
+## arg 1: the new package version
+## arg 2: the old package version
+#post_upgrade() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#pre_remove() {
+ # do something here
+#}
+
+## arg 1: the old package version
+#post_remove() {
+ # do something here
+#}