summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCritzlez2020-03-15 00:59:41 -0700
committerCritzlez2020-03-15 00:59:41 -0700
commit39694e8b71894d3b59ea5a14587a02ae25b417cf (patch)
treef58495de3e5805476d5a1726b878f96b18ef3670
downloadaur-39694e8b71894d3b59ea5a14587a02ae25b417cf.tar.gz
package init
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD34
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..443bc1cfc597
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = detect-tablet-mode-git
+ pkgdesc = Detects both normal & tablet mode, executing custom scripts/commands for each mode. See the github page for instructions.
+ pkgver = master
+ pkgrel = 1
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = ruby
+ depends = libinput
+ provides = libinput
+ source = detect-tablet-mode-git::git+https://github.com/alesguzik/linux_detect_tablet_mode
+ sha256sums = SKIP
+
+pkgname = detect-tablet-mode-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..56b02ba0b08f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+# Maintainer: James Armstrong <jm.armstrong1207@gmail.com>
+pkgname=detect-tablet-mode-git
+pkgver=master
+pkgrel=1
+pkgdesc="Detects both normal & tablet mode, executing custom scripts/commands for each mode. See the github page for instructions."
+arch=('any')
+url=""
+license=('GPL')
+groups=()
+depends=('ruby' 'libinput')
+makedepends=('git')
+optdepends=()
+provides=('libinput')
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog=
+source=("$pkgname::git+https://github.com/alesguzik/linux_detect_tablet_mode")
+noextract=()
+sha256sums=('SKIP')
+#build() {
+#}
+
+package() {
+ cd $pkgname
+
+ install -d $pkgdir/usr/bin
+ install -d $pkdir/home/$USER/.config/
+
+ cp watch_tablet $pkgdir/usr/bin
+ cp watch_tablet.yml $pkdir/home/$USER/.config
+}