summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Runge2023-03-21 21:51:17 +0000
committerDavid Runge2023-03-21 21:51:17 +0000
commit28a8f4553cef5252b52323767d97d1907fee7fc7 (patch)
treee6c7d2d15094947a7538fc59038c27c0d37295c2
parentb0684f9dd454d0cdf5e998a80e6d3d11bbccb590 (diff)
downloadaur-28a8f4553cef5252b52323767d97d1907fee7fc7.tar.gz
Rebuild to re-sign package.
Remove unnecessary quotes and curly braces. Ignore broken lv2lint tests, as upstream ignores the issues: https://github.com/blablack/deteriorate-lv2/issues/10 Use install instead of waf in package() as ancient waf is (of course) broken.
-rw-r--r--PKGBUILD70
1 files changed, 50 insertions, 20 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 54000f478f7c..bf11c7cab800 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,39 @@
pkgname=deteriorate-lv2
pkgver=1.0.7
-pkgrel=3
+pkgrel=4
pkgdesc="A set of plugins to deteriorate the sound quality of a live input"
-arch=('x86_64')
+arch=(x86_64)
url="https://github.com/blablack/deteriorate-lv2"
-license=('GPL3')
-groups=('lv2-plugins' 'pro-audio')
-depends=('fontconfig' 'gcc-libs' 'glibc' 'gtkmm')
-makedepends=('atkmm' 'cairomm' 'freetype2' 'glib2' 'glibmm' 'libsigc++' 'lv2'
-'lvtk' 'pango' 'waf')
-checkdepends=('lv2lint')
-source=("$pkgname-$pkgver.tar.gz::https://github.com/blablack/${pkgname}/archive/v${pkgver}.tar.gz")
+license=(GPL3)
+groups=(
+ lv2-plugins
+ pro-audio
+)
+depends=(
+ gcc-libs
+ glibc
+ gtkmm
+)
+makedepends=(
+ atkmm
+ cairomm
+ freetype2
+ glib2
+ glibmm
+ libsigc++
+ lv2
+ lvtk
+ pango
+ waf
+)
+checkdepends=(lv2lint)
+source=($url/archive/v$pkgver/$pkgname-v$pkgver.tar.gz)
sha512sums=('dec154c7f45cb69906245993e03d5551ff06a052d50fae753d52643a1cf9ed60479c76d586bd0e9b7606cd4e5b3b866e80a791b9c21dd6cdd7415f9687ff847e')
b2sums=('6ee4f790f143bb3756acdcbecab5f339fa53afbb1443a811c35c8ca74cd71b1bef6d43be5ef67d15d694f1a76b01c714b40e64e945f2443f769ee15abb4db8ad')
prepare() {
- cd "${pkgname}-${pkgver}"
+ cd $pkgname-$pkgver
# let wscript(s) find the custom waf scripts
mkdir -pv tools
touch __init__.py
@@ -32,7 +49,7 @@ prepare() {
}
build() {
- cd "$pkgname-$pkgver"
+ cd $pkgname-$pkgver
export LINKFLAGS="$LDFLAGS"
waf configure --prefix=/usr
waf
@@ -40,18 +57,31 @@ build() {
check() {
local _name
- cd "$pkgname-$pkgver"
+ local lv2lint_options=(
+ # disable broken tests, as upstream does not care: https://github.com/blablack/deteriorate-lv2/issues/10
+ -t "Plugin Symbols"
+ -t "UI Symbols"
+ -t "Plugin Version Minor"
+ -t "Plugin Version Micro"
+ -Mpack
+ -I "$pkgname-$pkgver/build/${pkgname//-/.}/"
+ )
+
for _name in {downsampler_{mono,stereo},granulator_{mono,stereo}}; do
- lv2lint -Mpack \
- -I "build/${pkgname//-/.}" \
- "https://github.com/blablack/deteriorate-lv2/${_name}" \
- || echo "Known to fail: https://github.com/blablack/deteriorate-lv2/issues/10"
+ lv2lint "${lv2lint_options[@]}" "http://github.com/blablack/deteriorate-lv2/${_name}"
done
}
package() {
- depends+=('libatkmm-1.6.so' 'libcairomm-1.0.so' 'libglibmm-2.4.so' 'libsigc-2.0.so')
- cd "$pkgname-$pkgver"
- waf install --destdir="$pkgdir/"
- install -vDm 644 {THANKS,README.md} -t "${pkgdir}/usr/share/doc/${pkgname}"
+ depends+=(
+ atkmm libatkmm-1.6.so
+ cairomm libcairomm-1.0.so
+ glibmm libglibmm-2.4.so
+ libsigc++ libsigc-2.0.so
+ )
+
+ cd $pkgname-$pkgver
+ install -vDm 755 build/${pkgname//-/.}/*.so -t "$pkgdir/usr/lib/lv2/${pkgname//-/.}/"
+ install -vDm 644 build/${pkgname//-/.}/*.ttl -t "$pkgdir/usr/lib/lv2/${pkgname//-/.}/"
+ install -vDm 644 {THANKS,README.md} -t "$pkgdir/usr/share/doc/$pkgname/"
}