summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicolas KAROLAK2020-01-30 13:12:06 +0100
committerNicolas KAROLAK2020-01-30 13:12:06 +0100
commit259c86c089711615d3fcd4c8c8b1f52667e40489 (patch)
tree3e5ccc0d5469a0d94e7d8aaad57f0e2bea18a7ae
parent27e32279b12544ba0f34390049522b5145cdaca2 (diff)
downloadaur-259c86c089711615d3fcd4c8c8b1f52667e40489.tar.gz
add makefile to help building/updating
-rw-r--r--Makefile31
1 files changed, 31 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 000000000000..3db9f23f55d3
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,31 @@
+.PHONY: all
+all:
+
+.PHONY: build
+## build: Build package
+build:
+ @echo "Building..."
+ @makepkg
+
+.PHONY: install
+## install: Install package
+install:
+ @echo "Installing..."
+ @makepkg --syncdeps --install --rmdeps
+
+.PHONY: sum
+## sum: Update the .SRCINFO file
+sum:
+ @makepkg --geninteg
+
+.PHONY: srcinfo
+## srcinfo: Update the .SRCINFO file
+srcinfo:
+ @echo "Updating srcinfo..."
+ @makepkg --printsrcinfo >| .SRCINFO
+
+.PHONY: help
+## help: Prints this help message
+help:
+ @echo "Usage: \n"
+ @sed -n 's/^##//p' ${MAKEFILE_LIST} | column -t -s ':' | sed -e 's/^/ /'