summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRadim Sückr2020-06-19 10:10:53 +0200
committerRadim Sückr2020-06-19 10:10:53 +0200
commit21dd8bc7569b24f9d1490c1d2d755d96405684c9 (patch)
tree24fcf781b286bff6f516d9e46f348a3e8daaa521
parente9416d1c79c833f9eaf467c927b1a11014a9db7e (diff)
downloadaur-21dd8bc7569b24f9d1490c1d2d755d96405684c9.tar.gz
Update to 0.0.37
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
-rw-r--r--setup.patch27
3 files changed, 60 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3abcf0dc73d3..409e51240955 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,28 +1,31 @@
pkgbase = developers-chamber
pkgdesc = Python developers utility library
- pkgver = 0.0.26
+ pkgver = 0.0.37
pkgrel = 1
url = https://github.com/druids/developers-chamber
arch = any
license = MIT
makedepends = python-setuptools
depends = python
+ depends = python-attrdict
depends = python-boto3
- depends = python-docker
depends = python-click
- depends = python-gitpython
- depends = python-requests
depends = python-click-completion
- depends = python-hosts
depends = python-coloredlogs
+ depends = python-docker
depends = python-dotenv
+ depends = python-gitpython
+ depends = python-hosts
depends = python-isort
depends = python-jira
- depends = python-unidecode
- depends = python-attrdict
+ depends = python-oauthlib
+ depends = python-requests
depends = python-togglpy
+ depends = python-unidecode
source = git+https://github.com/druids/developers-chamber.git
+ source = setup.patch
sha512sums = SKIP
+ sha512sums = d5f5879d6a23c7dfc15e9a0736936b211d052f20a5cc3aa88dc88d75007c93844dced7b1b4a051a11b8c347cf6aa8a5656a01e2c79ab3df15e243f5032df0fcf
pkgname = developers-chamber
diff --git a/PKGBUILD b/PKGBUILD
index 222d822a1d10..5a6289885d1a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,38 @@
# Maintainer: Radim Sückr <contact@radimsuckr.cz>
pkgname=developers-chamber
-pkgver=0.0.26
+pkgver=0.0.37
pkgrel=1
pkgdesc='Python developers utility library'
arch=('any')
url='https://github.com/druids/developers-chamber'
license=('MIT')
-depends=('python' 'python-boto3' 'python-docker' 'python-click' 'python-gitpython' 'python-requests' 'python-click-completion' 'python-hosts' 'python-coloredlogs' 'python-dotenv' 'python-isort' 'python-jira' 'python-unidecode' 'python-attrdict' 'python-togglpy')
+depends=(
+ 'python'
+ 'python-attrdict'
+ 'python-boto3'
+ 'python-click'
+ 'python-click-completion'
+ 'python-coloredlogs'
+ 'python-docker'
+ 'python-dotenv'
+ 'python-gitpython'
+ 'python-hosts'
+ 'python-isort'
+ 'python-jira'
+ 'python-oauthlib'
+ 'python-requests'
+ 'python-togglpy'
+ 'python-unidecode'
+)
makedepends=('python-setuptools')
-source=('git+https://github.com/druids/developers-chamber.git')
-sha512sums=('SKIP')
+source=('git+https://github.com/druids/developers-chamber.git' 'setup.patch')
+sha512sums=('SKIP'
+ 'd5f5879d6a23c7dfc15e9a0736936b211d052f20a5cc3aa88dc88d75007c93844dced7b1b4a051a11b8c347cf6aa8a5656a01e2c79ab3df15e243f5032df0fcf')
prepare() {
cd ${pkgname}
+ patch --forward --strip=1 --input="${srcdir}/setup.patch"
python setup.py build
}
diff --git a/setup.patch b/setup.patch
new file mode 100644
index 000000000000..f863c545fce2
--- /dev/null
+++ b/setup.patch
@@ -0,0 +1,27 @@
+diff --git a/setup.py b/setup.py
+index c421188..73748f7 100644
+--- a/setup.py
++++ b/setup.py
+@@ -12,22 +12,6 @@ setup(
+ package_dir={'developers_chamber': 'developers_chamber'},
+ include_package_data=True,
+ packages=find_packages(),
+- install_requires=[
+- 'oauthlib==3.1.0',
+- 'gitpython==3.1.0',
+- 'click==7.0',
+- 'requests==2.23.0',
+- 'python-dotenv==0.10.3',
+- 'boto3==1.9.230',
+- 'python-hosts==0.4.6',
+- 'isort==4.3.21',
+- 'coloredlogs==10.0',
+- 'click-completion==0.5.2',
+- 'jira==2.0.0',
+- 'unidecode==1.1.1',
+- 'TogglPy==0.1.1',
+- 'attrdict==2.0.1',
+- ],
+ entry_points={'console_scripts': [
+ 'pydev=developers_chamber.bin.pydev:cli',
+ ]},