summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Carlier2017-04-05 08:44:12 +0000
committerDavid Carlier2017-04-05 08:44:12 +0000
commit99bc87bd4c8791743f86bdbb7d055266072f6ae5 (patch)
tree7259e6a3acacf1e4eda0eb66cd3745e72eed4fae
downloadaur-deviceatlas-enterprise-c.tar.gz
initial commit of deviceatlas C api package
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD33
-rw-r--r--deviceatlas-enterprise-c-src-cmakelists.patch10
3 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f60eabcf2f23
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = deviceatlas-enterprise-c
+ pkgdesc = DeviceAtlas enterprise C API
+ pkgver = 2.1.2_1
+ pkgrel = 1
+ url = https://deviceatlas.com/deviceatlas-haproxy-module
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = cmake
+ depends = pcre
+ source = deviceatlas-enterprise-c-2.1.2_1.tgz::file://deviceatlas-enterprise-c-2.1.2_1.tgz
+ source = deviceatlas-enterprise-c-src-cmakelists.patch
+ md5sums = ac23e436ff408ef9a4377c68e2609173
+ md5sums = f888cc250a58aa1e26bc4d1e2ecda838
+
+pkgname = deviceatlas-enterprise-c
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4df6f29464c7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,33 @@
+# In order to get the DeviceAtlas enterprise C api and a limited JSON data file,
+# you need to visit https://deviceatlas.com/deviceatlas-haproxy-module
+# and register to get a license key. If you want to upgrade your license,
+# please visit this page https://deviceatlas.com/contact-us
+
+# Maintainer: David Carlier <devnexen@gmail.com>
+pkgname=deviceatlas-enterprise-c
+pkgver=2.1.2_1
+pkgrel=1
+pkgdesc="DeviceAtlas enterprise C API"
+arch=('i686' 'x86_64')
+url="https://deviceatlas.com/deviceatlas-haproxy-module"
+license=('unknown')
+depends=('pcre')
+makedepends=('cmake')
+source=("$pkgname-$pkgver.tgz::file://$pkgname-$pkgver.tgz" "$pkgname-src-cmakelists.patch")
+md5sums=('ac23e436ff408ef9a4377c68e2609173' 'f888cc250a58aa1e26bc4d1e2ecda838')
+
+prepare() {
+ cd $pkgname-$pkgver
+ patch -p0 -i ../$pkgname-src-cmakelists.patch
+}
+
+build() {
+ cd $pkgname-$pkgver
+ cmake .
+ make
+}
+
+package() {
+ cd $pkgname-$pkgver
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/deviceatlas-enterprise-c-src-cmakelists.patch b/deviceatlas-enterprise-c-src-cmakelists.patch
new file mode 100644
index 000000000000..a979d3747085
--- /dev/null
+++ b/deviceatlas-enterprise-c-src-cmakelists.patch
@@ -0,0 +1,10 @@
+--- Src/CMakeLists.txt.orig 2017-04-03 14:31:01.110259132 +0000
++++ Src/CMakeLists.txt 2017-04-03 14:31:20.492746817 +0000
+@@ -37,5 +37,5 @@
+ set (CMAKE_SHARED_LINKER_FLAGS -m32)
+ endif()
+
+-install(FILES libda.so libda.so.${API_VERSION} DESTINATION /usr/local/lib)
+-install(FILES dac.h dac_json.h DESTINATION /usr/local/include)
++install(FILES libda.so libda.so.${API_VERSION} DESTINATION /usr/lib)
++install(FILES dac.h dac_json.h DESTINATION /usr/include)