summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAnton Leontiev2014-05-15 12:32:09 +0400
committerAnton Leontiev2015-02-15 07:48:21 +0300
commit6708c039087ba8ed61962ee581a237a18b4fd82a (patch)
treecad36669f3a519b45ac615ad1f7d38b3bb255499
downloadaur-6708c039087ba8ed61962ee581a237a18b4fd82a.tar.gz
Adopted v1.7.8-2
-rw-r--r--.SRCINFO25
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD40
-rw-r--r--devil.install11
-rw-r--r--libpng14.patch33
5 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..06dc3ac6ba3d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,25 @@
+pkgbase = devil-ilut
+ pkgdesc = Library for reading several different image formats (includes ILUT)
+ pkgver = 1.7.8
+ pkgrel = 2
+ url = http://openil.sourceforge.net/
+ install = devil.install
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpng
+ depends = libmng
+ depends = jasper
+ depends = lcms
+ depends = openexr
+ provides = devil
+ conflicts = devil
+ options = !docs
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/openil/DevIL-1.7.8.tar.gz
+ source = libpng14.patch
+ md5sums = 7918f215524589435e5ec2e8736d5e1d
+ md5sums = 0f839ccefd43b0ee8b4b3f99806147fc
+
+pkgname = devil-ilut
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..243b79dd6dcc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Contributor: Anton Leontiev <bunder /at/ t-25.ru>
+# Contributor: Clemens John <clemens-john@gmx.de>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: TheHoff <forums>
+
+pkgname=devil-ilut
+pkgver=1.7.8
+pkgrel=2
+pkgdesc='Library for reading several different image formats (includes ILUT)'
+arch=('i686' 'x86_64')
+url='http://openil.sourceforge.net/'
+depends=('libpng' 'libmng' 'jasper' 'lcms' 'openexr') # libjpeg & libtiff are implicitly satisfied
+install=devil.install
+options=('!docs' '!emptydirs')
+license=('GPL')
+provides=('devil')
+conflicts=('devil')
+source=(http://downloads.sourceforge.net/openil/DevIL-$pkgver.tar.gz libpng14.patch)
+md5sums=('7918f215524589435e5ec2e8736d5e1d'
+ '0f839ccefd43b0ee8b4b3f99806147fc')
+
+build() {
+ cd devil-$pkgver
+ patch -Np1 -i ../libpng14.patch
+
+ if [[ $CARCH != x86_64 ]]; then
+ OPTIMIZATION=--disable-sse3
+ fi
+
+ ./configure --prefix=/usr --enable-ILU --enable-ILUT \
+ --enable-jpeg --enable-tiff --disable-squish --disable-lcms \
+ --disable-sdl --disable-x11 --disable-opengl --disable-shm --disable-render $OPTIMIZATION
+
+ make
+}
+
+package() {
+ cd devil-$pkgver
+ make prefix="${pkgdir}/usr" install
+}
diff --git a/devil.install b/devil.install
new file mode 100644
index 000000000000..8336ac3d1472
--- /dev/null
+++ b/devil.install
@@ -0,0 +1,11 @@
+infodir=usr/share/info
+
+post_upgrade() {
+ [ -x usr/bin/install-info ] || return 0
+ install-info $infodir/DevIL_manual.info.gz $infodir/dir 2> /dev/null
+}
+
+pre_remove() {
+ [ -x usr/bin/install-info ] || return 0
+ install-info --delete $infodir/DevIL_manual.info.gz $infodir/dir 2> /dev/null
+}
diff --git a/libpng14.patch b/libpng14.patch
new file mode 100644
index 000000000000..b8434692b8bd
--- /dev/null
+++ b/libpng14.patch
@@ -0,0 +1,33 @@
+diff -Nur devil-1.7.8.orig/src-IL/src/il_icon.c devil-1.7.8/src-IL/src/il_icon.c
+--- devil-1.7.8.orig/src-IL/src/il_icon.c 2009-03-08 09:10:09.000000000 +0200
++++ devil-1.7.8/src-IL/src/il_icon.c 2010-01-17 00:54:09.000000000 +0200
+@@ -525,7 +525,7 @@
+
+ // Expand low-bit-depth grayscale images to 8 bits
+ if (ico_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
+- png_set_gray_1_2_4_to_8(ico_png_ptr);
++ png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
+ }
+
+ // Expand RGB images with transparency to full alpha channels
+diff -Nur devil-1.7.8.orig/src-IL/src/il_png.c devil-1.7.8/src-IL/src/il_png.c
+--- devil-1.7.8.orig/src-IL/src/il_png.c 2009-03-08 09:10:09.000000000 +0200
++++ devil-1.7.8/src-IL/src/il_png.c 2010-01-17 00:55:26.000000000 +0200
+@@ -105,7 +105,7 @@
+ Read = iread(Signature, 1, 8);
+ iseek(-Read, IL_SEEK_CUR);
+
+- return png_check_sig(Signature, 8);
++ return png_sig_cmp(Signature, 0, 8) == 0;
+ }
+
+
+@@ -278,7 +278,7 @@
+
+ // Expand low-bit-depth grayscale images to 8 bits
+ if (png_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ // Expand RGB images with transparency to full alpha channels