summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander 'z33ky' Hirsch2017-06-02 12:13:33 +0200
committerAlexander 'z33ky' Hirsch2017-06-02 12:13:33 +0200
commit0192d82ecbc77eb6422d23bcf76141d0bc8fd777 (patch)
tree0063c17956571ba4c53e189a73053d2e60ff69e8
parent048f0b4c58e1c049213c1d10f8a7d269b0ed1be3 (diff)
downloadaur-0192d82ecbc77eb6422d23bcf76141d0bc8fd777.tar.gz
Add hide-endian-functions.patch and fix opengl.patch
hide-endian-functions.patch is required for quake2xp, since it uses the same function names.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD11
-rw-r--r--hide-endian-functions.patch20
-rw-r--r--opengl.patch12
4 files changed, 39 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bed8a3f01589..3c300769f6b6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
# Generated by mksrcinfo v8
-# Fri Jun 2 08:13:02 UTC 2017
+# Fri Jun 2 10:13:13 UTC 2017
pkgbase = devil-ilut-vanilla
pkgdesc = Library for reading several different image formats (includes ILUT & doesn't --{dis,en}able more than that)
pkgver = 1.8.0
- pkgrel = 1
+ pkgrel = 2
url = http://openil.sourceforge.net/
arch = i686
arch = x86_64
@@ -19,9 +19,11 @@ pkgbase = devil-ilut-vanilla
options = !docs
options = !emptydirs
source = http://downloads.sourceforge.net/openil/DevIL-1.8.0.tar.gz
+ source = hide-endian-functions.patch
source = opengl.patch
md5sums = 4d8c21aa4822ac86d77e44f8d7c9becd
- md5sums = 17413db6a911bf73bf5e3fcdb9aeac27
+ md5sums = aea342d8ef0be8542901bf693fbcec72
+ md5sums = 7042e399ee812cbc624256914c9c50b0
pkgname = devil-ilut-vanilla
diff --git a/PKGBUILD b/PKGBUILD
index aa2a5915de74..2f6afa1485aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,7 +7,7 @@
pkgname=devil-ilut-vanilla
# "vanilla" as in doesn't add more --enable or --disable flags than neccesary for ILUT
pkgver=1.8.0
-pkgrel=1
+pkgrel=2
pkgdesc="Library for reading several different image formats (includes ILUT & doesn't --{dis,en}able more than that)"
arch=('i686' 'x86_64')
url='http://openil.sourceforge.net/'
@@ -18,12 +18,17 @@ license=('GPL')
provides=('devil')
conflicts=('devil')
source=(http://downloads.sourceforge.net/openil/DevIL-$pkgver.tar.gz
+ hide-endian-functions.patch
opengl.patch)
md5sums=('4d8c21aa4822ac86d77e44f8d7c9becd'
- '17413db6a911bf73bf5e3fcdb9aeac27')
+ 'aea342d8ef0be8542901bf693fbcec72'
+ '7042e399ee812cbc624256914c9c50b0')
prepare() {
- cd ${srcdir}/DevIL
+ cd "${srcdir}/DevIL/DevIL"
+
+ patch -p1 -i "${srcdir}/hide-endian-functions.patch"
+ patch -p1 -i "${srcdir}/opengl.patch"
}
build() {
diff --git a/hide-endian-functions.patch b/hide-endian-functions.patch
new file mode 100644
index 000000000000..83ae5f47dc0f
--- /dev/null
+++ b/hide-endian-functions.patch
@@ -0,0 +1,20 @@
+--- a/src-IL/include/il_endian.h 2017-06-02 12:05:55.321355203 +0200
++++ b/src-IL/include/il_endian.h 2017-06-02 11:57:47.210954830 +0200
+@@ -68,6 +68,8 @@ extern "C" {
+ #define INLINE
+ #endif
+
++#pragma GCC visibility push(hidden)
++
+ void iSwapUShort(ILushort *s);
+ void iSwapShort(ILshort *s);
+ void iSwapUInt(ILuint *i);
+@@ -101,6 +103,8 @@ ILubyte SaveBigDouble(ILdouble d);
+
+ void EndianSwapData(void *_Image);
+
++#pragma GCC visibility pop
++
+ #ifdef __cplusplus
+ }
+ #endif
diff --git a/opengl.patch b/opengl.patch
index da94c73c47e9..f92e911f400a 100644
--- a/opengl.patch
+++ b/opengl.patch
@@ -1,5 +1,5 @@
---- include/IL/ilut_config.h.old 2017-06-02 09:55:51.057995171 +0200
-+++ include/IL/ilut_config.h 2017-06-02 09:56:03.494411426 +0200
+--- a/include/IL/ilut_config.h 2017-06-02 09:55:51.057995171 +0200
++++ b/include/IL/ilut_config.h 2017-06-02 09:56:03.494411426 +0200
@@ -16,11 +16,11 @@
//
#undef ILUT_USE_ALLEGRO
@@ -14,8 +14,8 @@
+//#define ILUT_USE_WIN32
#endif//__ILUT_CONFIG_H__
---- include/IL/ilut.h.old 2017-06-02 09:54:48.259185625 +0200
-+++ include/IL/ilut.h 2017-06-02 09:54:55.892381093 +0200
+--- a/include/IL/ilut.h 2017-06-02 09:54:48.259185625 +0200
++++ b/include/IL/ilut.h 2017-06-02 09:54:55.892381093 +0200
@@ -96,10 +96,10 @@
#pragma comment(lib, "ILUT.lib")
#endif
@@ -29,8 +29,8 @@
---- src-ILUT/pkgconfig/ILUT.pc.cmake.in.old 2017-06-02 10:09:04.646074566 +0200
-+++ src-ILUT/pkgconfig/ILUT.pc.cmake.in 2017-06-02 10:09:19.438930975 +0200
+--- a/src-ILUT/pkgconfig/ILUT.pc.cmake.in 2017-06-02 10:09:04.646074566 +0200
++++ b/src-ILUT/pkgconfig/ILUT.pc.cmake.in 2017-06-02 10:09:19.438930975 +0200
@@ -10,5 +10,5 @@ URL: http://openil.sourceforge.net
Requires: IL ILU
Cflags: -I${includedir}