summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander 'z33ky' Hirsch2017-06-02 10:17:27 +0200
committerAlexander 'z33ky' Hirsch2017-06-02 10:17:27 +0200
commit048f0b4c58e1c049213c1d10f8a7d269b0ed1be3 (patch)
tree3c477eb0177831461b03287fdb299a7654625208
parent0dfdc34803047288a9fbc62195774785dc881804 (diff)
downloadaur-048f0b4c58e1c049213c1d10f8a7d269b0ed1be3.tar.gz
Update to 1.8.0
OpenGL support doesn't seem to get built in, so a patch is provided. This is not the cleanest method, but it works I guess.
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD33
-rw-r--r--gcc-5.0.patch45
-rw-r--r--libpng14.patch33
-rw-r--r--opengl.patch40
5 files changed, 59 insertions, 107 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0290e5c07165..bed8a3f01589 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,14 @@
# Generated by mksrcinfo v8
-# Mon May 30 23:33:34 UTC 2016
+# Fri Jun 2 08:13:02 UTC 2017
pkgbase = devil-ilut-vanilla
pkgdesc = Library for reading several different image formats (includes ILUT & doesn't --{dis,en}able more than that)
- pkgver = 1.7.8
+ pkgver = 1.8.0
pkgrel = 1
url = http://openil.sourceforge.net/
arch = i686
arch = x86_64
license = GPL
+ makedepends = cmake
depends = libpng
depends = libmng
depends = jasper
@@ -17,12 +18,10 @@ pkgbase = devil-ilut-vanilla
conflicts = devil
options = !docs
options = !emptydirs
- source = http://downloads.sourceforge.net/openil/DevIL-1.7.8.tar.gz
- source = libpng14.patch
- source = gcc-5.0.patch
- md5sums = 7918f215524589435e5ec2e8736d5e1d
- md5sums = 0f839ccefd43b0ee8b4b3f99806147fc
- md5sums = 8d1b5d973c93927f60f775aecb448e77
+ source = http://downloads.sourceforge.net/openil/DevIL-1.8.0.tar.gz
+ source = opengl.patch
+ md5sums = 4d8c21aa4822ac86d77e44f8d7c9becd
+ md5sums = 17413db6a911bf73bf5e3fcdb9aeac27
pkgname = devil-ilut-vanilla
diff --git a/PKGBUILD b/PKGBUILD
index 4aee035fe08e..aa2a5915de74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,47 +6,38 @@
pkgname=devil-ilut-vanilla
# "vanilla" as in doesn't add more --enable or --disable flags than neccesary for ILUT
-pkgver=1.7.8
+pkgver=1.8.0
pkgrel=1
pkgdesc="Library for reading several different image formats (includes ILUT & doesn't --{dis,en}able more than that)"
arch=('i686' 'x86_64')
url='http://openil.sourceforge.net/'
+makedepends=('cmake')
depends=('libpng' 'libmng' 'jasper' 'lcms' 'openexr')
options=('!docs' '!emptydirs')
license=('GPL')
provides=('devil')
conflicts=('devil')
source=(http://downloads.sourceforge.net/openil/DevIL-$pkgver.tar.gz
- libpng14.patch
- gcc-5.0.patch)
-md5sums=('7918f215524589435e5ec2e8736d5e1d'
- '0f839ccefd43b0ee8b4b3f99806147fc'
- '8d1b5d973c93927f60f775aecb448e77')
+ opengl.patch)
+md5sums=('4d8c21aa4822ac86d77e44f8d7c9becd'
+ '17413db6a911bf73bf5e3fcdb9aeac27')
prepare() {
- cd ${srcdir}/devil-$pkgver
-
- patch -Np1 -i ${srcdir}/libpng14.patch
- patch -Np1 -i ${srcdir}/gcc-5.0.patch
-
- # link against libpng.so, not libpng12.so
- sed -i 's/png12/png/g' configure m4/devil-definitions.m4
+ cd ${srcdir}/DevIL
}
build() {
- cd ${srcdir}/devil-$pkgver
+ mkdir -p "${srcdir}/DevIL/DevIL/build"
+ cd "${srcdir}/DevIL/DevIL/build"
- if [[ $CARCH == x86_64 ]]; then
- ./configure --prefix=/usr --enable-ILU --enable-ILUT
- else
- ./configure --prefix=/usr --enable-ILU --enable-ILUT --disable-sse3
- fi
+ cmake -DCMAKE_BUILD_TYPE=Release -DCMAKE_INSTALL_PREFIX=/usr ..
make
}
package() {
- cd ${srcdir}/devil-$pkgver
+ cd "${srcdir}/DevIL/DevIL/build"
- make prefix=${pkgdir}/usr install
+ DESTDIR="${pkgdir}" make install
+ install -Dm644 ../include/IL/ilut_config.h "${pkgdir}/usr/include/IL/"
}
diff --git a/gcc-5.0.patch b/gcc-5.0.patch
deleted file mode 100644
index 6e7883754f19..000000000000
--- a/gcc-5.0.patch
+++ /dev/null
@@ -1,45 +0,0 @@
-diff -ru devil-1.7.8/src-IL/src/il_exr.cpp devil-1.7.8a/src-IL/src/il_exr.cpp
---- devil-1.7.8/src-IL/src/il_exr.cpp 2009-03-08 08:10:09.000000000 +0100
-+++ devil-1.7.8a/src-IL/src/il_exr.cpp 2015-05-15 18:50:35.700339353 +0200
-@@ -11,6 +11,7 @@
- //-----------------------------------------------------------------------------
-
-
-+#include "il.h"
- #include "il_internal.h"
- #ifndef IL_NO_EXR
-
-diff -ru devil-1.7.8/src-IL/src/il_nvidia.cpp devil-1.7.8a/src-IL/src/il_nvidia.cpp
---- devil-1.7.8/src-IL/src/il_nvidia.cpp 2009-03-08 08:10:09.000000000 +0100
-+++ devil-1.7.8a/src-IL/src/il_nvidia.cpp 2015-05-15 18:50:46.490308339 +0200
-@@ -11,6 +11,7 @@
- //-----------------------------------------------------------------------------
-
-
-+#include "il.h"
- #include "il_internal.h"
- #include "il_dds.h"
- #include "il_manip.h"
-diff -ru devil-1.7.8/src-IL/src/il_squish.cpp devil-1.7.8a/src-IL/src/il_squish.cpp
---- devil-1.7.8/src-IL/src/il_squish.cpp 2009-03-08 08:10:09.000000000 +0100
-+++ devil-1.7.8a/src-IL/src/il_squish.cpp 2015-05-15 18:56:13.935820622 +0200
-@@ -11,6 +11,7 @@
- //-----------------------------------------------------------------------------
-
-
-+#include "il.h"
- #include "il_internal.h"
- /*#include "il_dds.h"
- #include "il_manip.h"
-diff -ru devil-1.7.8/src-IL/src/il_utx.cpp devil-1.7.8a/src-IL/src/il_utx.cpp
---- devil-1.7.8/src-IL/src/il_utx.cpp 2009-03-08 08:10:09.000000000 +0100
-+++ devil-1.7.8a/src-IL/src/il_utx.cpp 2015-05-15 18:56:33.572405684 +0200
-@@ -12,6 +12,8 @@
- //
- //-----------------------------------------------------------------------------
-
-+
-+#include "il.h"
- #include "il_internal.h"
- #ifndef IL_NO_UTX
- #include "il_utx.h"
diff --git a/libpng14.patch b/libpng14.patch
deleted file mode 100644
index b8434692b8bd..000000000000
--- a/libpng14.patch
+++ /dev/null
@@ -1,33 +0,0 @@
-diff -Nur devil-1.7.8.orig/src-IL/src/il_icon.c devil-1.7.8/src-IL/src/il_icon.c
---- devil-1.7.8.orig/src-IL/src/il_icon.c 2009-03-08 09:10:09.000000000 +0200
-+++ devil-1.7.8/src-IL/src/il_icon.c 2010-01-17 00:54:09.000000000 +0200
-@@ -525,7 +525,7 @@
-
- // Expand low-bit-depth grayscale images to 8 bits
- if (ico_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
-- png_set_gray_1_2_4_to_8(ico_png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
- }
-
- // Expand RGB images with transparency to full alpha channels
-diff -Nur devil-1.7.8.orig/src-IL/src/il_png.c devil-1.7.8/src-IL/src/il_png.c
---- devil-1.7.8.orig/src-IL/src/il_png.c 2009-03-08 09:10:09.000000000 +0200
-+++ devil-1.7.8/src-IL/src/il_png.c 2010-01-17 00:55:26.000000000 +0200
-@@ -105,7 +105,7 @@
- Read = iread(Signature, 1, 8);
- iseek(-Read, IL_SEEK_CUR);
-
-- return png_check_sig(Signature, 8);
-+ return png_sig_cmp(Signature, 0, 8) == 0;
- }
-
-
-@@ -278,7 +278,7 @@
-
- // Expand low-bit-depth grayscale images to 8 bits
- if (png_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
-- png_set_gray_1_2_4_to_8(png_ptr);
-+ png_set_expand_gray_1_2_4_to_8(png_ptr);
- }
-
- // Expand RGB images with transparency to full alpha channels
diff --git a/opengl.patch b/opengl.patch
new file mode 100644
index 000000000000..da94c73c47e9
--- /dev/null
+++ b/opengl.patch
@@ -0,0 +1,40 @@
+--- include/IL/ilut_config.h.old 2017-06-02 09:55:51.057995171 +0200
++++ include/IL/ilut_config.h 2017-06-02 09:56:03.494411426 +0200
+@@ -16,11 +16,11 @@
+ //
+ #undef ILUT_USE_ALLEGRO
+
+-#undef ILUT_USE_DIRECTX8
++//#undef ILUT_USE_DIRECTX8
+ //#define ILUT_USE_DIRECTX9
+ //#define ILUT_USE_DIRECTX10
+ #define ILUT_USE_OPENGL
+ //#define ILUT_USE_SDL
+-#define ILUT_USE_WIN32
++//#define ILUT_USE_WIN32
+
+ #endif//__ILUT_CONFIG_H__
+--- include/IL/ilut.h.old 2017-06-02 09:54:48.259185625 +0200
++++ include/IL/ilut.h 2017-06-02 09:54:55.892381093 +0200
+@@ -96,10 +96,10 @@
+ #pragma comment(lib, "ILUT.lib")
+ #endif
+ #endif
+-
+- #include <IL/ilut_config.h>
+ #endif
+
++#include <IL/ilut_config.h>
++
+
+
+
+--- src-ILUT/pkgconfig/ILUT.pc.cmake.in.old 2017-06-02 10:09:04.646074566 +0200
++++ src-ILUT/pkgconfig/ILUT.pc.cmake.in 2017-06-02 10:09:19.438930975 +0200
+@@ -10,5 +10,5 @@ URL: http://openil.sourceforge.net
+ Requires: IL ILU
+ Cflags: -I${includedir}
+ Libs: -L${libdir} -lILUT
+-Libs.private: -lIL -lILU
++Libs.private: -lIL -lILU -lGL -lGLU
+