summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlexander 'z33ky' Hirsch2016-05-31 01:36:16 +0200
committerAlexander 'z33ky' Hirsch2016-05-31 01:36:16 +0200
commit0dfdc34803047288a9fbc62195774785dc881804 (patch)
tree5fd7058bd4fc72fec82b0ce84ae08e552b46c266
downloadaur-0dfdc34803047288a9fbc62195774785dc881804.tar.gz
Initial import
-rw-r--r--.SRCINFO28
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD52
-rw-r--r--gcc-5.0.patch45
-rw-r--r--libpng14.patch33
5 files changed, 164 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0290e5c07165
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+# Generated by mksrcinfo v8
+# Mon May 30 23:33:34 UTC 2016
+pkgbase = devil-ilut-vanilla
+ pkgdesc = Library for reading several different image formats (includes ILUT & doesn't --{dis,en}able more than that)
+ pkgver = 1.7.8
+ pkgrel = 1
+ url = http://openil.sourceforge.net/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = libpng
+ depends = libmng
+ depends = jasper
+ depends = lcms
+ depends = openexr
+ provides = devil
+ conflicts = devil
+ options = !docs
+ options = !emptydirs
+ source = http://downloads.sourceforge.net/openil/DevIL-1.7.8.tar.gz
+ source = libpng14.patch
+ source = gcc-5.0.patch
+ md5sums = 7918f215524589435e5ec2e8736d5e1d
+ md5sums = 0f839ccefd43b0ee8b4b3f99806147fc
+ md5sums = 8d1b5d973c93927f60f775aecb448e77
+
+pkgname = devil-ilut-vanilla
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e6b6b4b8077d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,6 @@
+*.tar.gz
+*.tar.bz2
+*.tar.xz
+*.tar.lz
+src/
+pkg/ \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4aee035fe08e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+# Maintainer: Alexander 'z33ky' Hirsch <1zeeky@gmail.com>
+# The following contributors are from community/devil
+# Contributor: Laurent Carlier <lordheavym@gmail.org>
+# Contributor: damir <damir@archlinux.org>
+# Contributor: TheHoff <forums>
+
+pkgname=devil-ilut-vanilla
+# "vanilla" as in doesn't add more --enable or --disable flags than neccesary for ILUT
+pkgver=1.7.8
+pkgrel=1
+pkgdesc="Library for reading several different image formats (includes ILUT & doesn't --{dis,en}able more than that)"
+arch=('i686' 'x86_64')
+url='http://openil.sourceforge.net/'
+depends=('libpng' 'libmng' 'jasper' 'lcms' 'openexr')
+options=('!docs' '!emptydirs')
+license=('GPL')
+provides=('devil')
+conflicts=('devil')
+source=(http://downloads.sourceforge.net/openil/DevIL-$pkgver.tar.gz
+ libpng14.patch
+ gcc-5.0.patch)
+md5sums=('7918f215524589435e5ec2e8736d5e1d'
+ '0f839ccefd43b0ee8b4b3f99806147fc'
+ '8d1b5d973c93927f60f775aecb448e77')
+
+prepare() {
+ cd ${srcdir}/devil-$pkgver
+
+ patch -Np1 -i ${srcdir}/libpng14.patch
+ patch -Np1 -i ${srcdir}/gcc-5.0.patch
+
+ # link against libpng.so, not libpng12.so
+ sed -i 's/png12/png/g' configure m4/devil-definitions.m4
+}
+
+build() {
+ cd ${srcdir}/devil-$pkgver
+
+ if [[ $CARCH == x86_64 ]]; then
+ ./configure --prefix=/usr --enable-ILU --enable-ILUT
+ else
+ ./configure --prefix=/usr --enable-ILU --enable-ILUT --disable-sse3
+ fi
+
+ make
+}
+
+package() {
+ cd ${srcdir}/devil-$pkgver
+
+ make prefix=${pkgdir}/usr install
+}
diff --git a/gcc-5.0.patch b/gcc-5.0.patch
new file mode 100644
index 000000000000..6e7883754f19
--- /dev/null
+++ b/gcc-5.0.patch
@@ -0,0 +1,45 @@
+diff -ru devil-1.7.8/src-IL/src/il_exr.cpp devil-1.7.8a/src-IL/src/il_exr.cpp
+--- devil-1.7.8/src-IL/src/il_exr.cpp 2009-03-08 08:10:09.000000000 +0100
++++ devil-1.7.8a/src-IL/src/il_exr.cpp 2015-05-15 18:50:35.700339353 +0200
+@@ -11,6 +11,7 @@
+ //-----------------------------------------------------------------------------
+
+
++#include "il.h"
+ #include "il_internal.h"
+ #ifndef IL_NO_EXR
+
+diff -ru devil-1.7.8/src-IL/src/il_nvidia.cpp devil-1.7.8a/src-IL/src/il_nvidia.cpp
+--- devil-1.7.8/src-IL/src/il_nvidia.cpp 2009-03-08 08:10:09.000000000 +0100
++++ devil-1.7.8a/src-IL/src/il_nvidia.cpp 2015-05-15 18:50:46.490308339 +0200
+@@ -11,6 +11,7 @@
+ //-----------------------------------------------------------------------------
+
+
++#include "il.h"
+ #include "il_internal.h"
+ #include "il_dds.h"
+ #include "il_manip.h"
+diff -ru devil-1.7.8/src-IL/src/il_squish.cpp devil-1.7.8a/src-IL/src/il_squish.cpp
+--- devil-1.7.8/src-IL/src/il_squish.cpp 2009-03-08 08:10:09.000000000 +0100
++++ devil-1.7.8a/src-IL/src/il_squish.cpp 2015-05-15 18:56:13.935820622 +0200
+@@ -11,6 +11,7 @@
+ //-----------------------------------------------------------------------------
+
+
++#include "il.h"
+ #include "il_internal.h"
+ /*#include "il_dds.h"
+ #include "il_manip.h"
+diff -ru devil-1.7.8/src-IL/src/il_utx.cpp devil-1.7.8a/src-IL/src/il_utx.cpp
+--- devil-1.7.8/src-IL/src/il_utx.cpp 2009-03-08 08:10:09.000000000 +0100
++++ devil-1.7.8a/src-IL/src/il_utx.cpp 2015-05-15 18:56:33.572405684 +0200
+@@ -12,6 +12,8 @@
+ //
+ //-----------------------------------------------------------------------------
+
++
++#include "il.h"
+ #include "il_internal.h"
+ #ifndef IL_NO_UTX
+ #include "il_utx.h"
diff --git a/libpng14.patch b/libpng14.patch
new file mode 100644
index 000000000000..b8434692b8bd
--- /dev/null
+++ b/libpng14.patch
@@ -0,0 +1,33 @@
+diff -Nur devil-1.7.8.orig/src-IL/src/il_icon.c devil-1.7.8/src-IL/src/il_icon.c
+--- devil-1.7.8.orig/src-IL/src/il_icon.c 2009-03-08 09:10:09.000000000 +0200
++++ devil-1.7.8/src-IL/src/il_icon.c 2010-01-17 00:54:09.000000000 +0200
+@@ -525,7 +525,7 @@
+
+ // Expand low-bit-depth grayscale images to 8 bits
+ if (ico_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
+- png_set_gray_1_2_4_to_8(ico_png_ptr);
++ png_set_expand_gray_1_2_4_to_8(ico_png_ptr);
+ }
+
+ // Expand RGB images with transparency to full alpha channels
+diff -Nur devil-1.7.8.orig/src-IL/src/il_png.c devil-1.7.8/src-IL/src/il_png.c
+--- devil-1.7.8.orig/src-IL/src/il_png.c 2009-03-08 09:10:09.000000000 +0200
++++ devil-1.7.8/src-IL/src/il_png.c 2010-01-17 00:55:26.000000000 +0200
+@@ -105,7 +105,7 @@
+ Read = iread(Signature, 1, 8);
+ iseek(-Read, IL_SEEK_CUR);
+
+- return png_check_sig(Signature, 8);
++ return png_sig_cmp(Signature, 0, 8) == 0;
+ }
+
+
+@@ -278,7 +278,7 @@
+
+ // Expand low-bit-depth grayscale images to 8 bits
+ if (png_color_type == PNG_COLOR_TYPE_GRAY && bit_depth < 8) {
+- png_set_gray_1_2_4_to_8(png_ptr);
++ png_set_expand_gray_1_2_4_to_8(png_ptr);
+ }
+
+ // Expand RGB images with transparency to full alpha channels