summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlarchunix2015-06-08 22:56:07 +0200
committerlarchunix2015-06-08 22:59:13 +0200
commit6ff6f5b3c41c1211e0f52b0d3d657c18ebe9bae8 (patch)
tree56114a9ae22ecc6030137b7f17fa119e764260b3
downloadaur-6ff6f5b3c41c1211e0f52b0d3d657c18ebe9bae8.tar.gz
Initial import
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD27
2 files changed, 45 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d7b4eadde250
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = devilspie2
+ pkgdesc = A window matching utility, allowing the user to perform scripted actions on windows as they are created.
+ pkgver = 0.39
+ pkgrel = 1
+ url = http://www.gusnan.se/devilspie2/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ depends = lua>=5.1
+ depends = gtk3
+ depends = libwnck3
+ source = http://download.savannah.gnu.org/releases/devilspie2/devilspie2_0.39-src.tar.gz
+ source = http://download.savannah.gnu.org/releases/devilspie2/devilspie2_0.39-src.tar.gz.asc
+ md5sums = e285228a4f6cef29e93898903725a1fb
+ md5sums = SKIP
+
+pkgname = devilspie2
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..75fcb1fe78ff
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+pkgname=devilspie2
+pkgver=0.39
+pkgrel=1
+pkgdesc="A window matching utility, allowing the user to perform scripted actions on windows as they are created."
+arch=('i686' 'x86_64')
+url="http://www.gusnan.se/$pkgname/"
+license=('GPL3')
+depends=('lua>=5.1' 'gtk3' 'libwnck3')
+source=("http://download.savannah.gnu.org/releases/$pkgname/${pkgname}_$pkgver-src.tar.gz"{,.asc})
+md5sums=('e285228a4f6cef29e93898903725a1fb'
+ 'SKIP')
+validpgpkeys=('DB306E4B10FFD98EF4DB55D7194B631AB2DA2888') # Andreas Rönnquist <gusnan@gusnan.se>
+
+build() {
+ cd "$pkgname-$pkgver"
+ make
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ make DESTDIR="$pkgdir/" PREFIX=/usr install
+
+ # Install documentation
+ install -o root -g root -m 644 -D README "$pkgdir/usr/share/doc/$pkgname/README"
+}
+
+# vim: set ft=sh ts=4 sw=4 noet: