summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLin Ruoshui2019-01-25 21:22:11 +0800
committerLin Ruoshui2019-01-25 21:22:11 +0800
commit9d4ac65e1bd6f669e43d7ef0c4a2c8ed413a536e (patch)
tree531432832844107b88e53ce686d9716671da45ae
downloadaur-9d4ac65e1bd6f669e43d7ef0c4a2c8ed413a536e.tar.gz
initial
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD44
2 files changed, 70 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..dc9ba5ffef19
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+# Generated by mksrcinfo v8
+# Fri Jan 25 13:21:00 UTC 2019
+pkgbase = devilutionx-git
+ pkgdesc = Diablo devolved for linux (git version)
+ pkgver = r1066.be85b3f
+ pkgrel = 1
+ url = https://github.com/diasurgical/devilutionX
+ arch = x86_64
+ license = custom:The Unlicense
+ makedepends = git
+ makedepends = cmake
+ makedepends = gcovr
+ makedepends = lib32-gcc-libs
+ makedepends = lib32-sdl2_mixer
+ makedepends = nasm
+ depends = sdl2_mixer
+ provides = devilutionx-git
+ conflicts = devilutionx-git
+ options = !strip
+ source = devilutionx-git::git+https://github.com/diasurgical/devilutionX.git
+ source = LICENSE::https://raw.githubusercontent.com/diasurgical/devilutionX/master/LICENSE
+ sha256sums = SKIP
+ sha256sums = 88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd
+
+pkgname = devilutionx-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3bfacb86ecf4
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+# Maintainer: LIN Ruohshoei <20455421+LinRs [dot] users.noreply.github.com>
+
+pkgname=devilutionx-git
+pkgver=r1066.be85b3f
+pkgrel=1
+pkgdesc="Diablo devolved for linux (git version)"
+arch=('x86_64')
+url="https://github.com/diasurgical/devilutionX"
+license=('custom:The Unlicense')
+depends=('sdl2_mixer')
+makedepends=('git' 'cmake' 'gcovr' 'lib32-gcc-libs' 'lib32-sdl2_mixer' 'nasm')
+provides=("${pkgname}")
+conflicts=("${pkgname}")
+options=('!strip')
+source=(
+ ${pkgname}::git+https://github.com/diasurgical/devilutionX.git
+ LICENSE::https://raw.githubusercontent.com/diasurgical/devilutionX/master/LICENSE
+ )
+noextract=()
+sha256sums=('SKIP'
+ '88d9b4eb60579c191ec391ca04c16130572d7eedc4a86daa58bf28c6e14c9bcd')
+pkgver() {
+ cd "$pkgname"
+ ( set -o pipefail
+ git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ )
+}
+
+build() {
+ cd "$srcdir/${pkgname}"
+ mkdir -p build && cd build
+ export SDL2_LIBRARIES="-L${SDL2_LIBDIR} -lSDL2 -lSDL2_image -lSDL2_mixer -lSDL2_ttf"
+ export CFLAGS="$CFLAGS -O0 -fbuiltin -g"
+ export CXXFLAGS="$CXXFLAGS -O0 -fbuiltin -g"
+ cmake .. \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ make devilution
+}
+package() {
+ cd "$srcdir/${pkgname}"
+ install -vDm755 build/devilution "${pkgdir}/usr/bin/devilution"
+ install -vDm644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname/"
+}